aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91
diff options
context:
space:
mode:
authorSandeep Sheriker M <sandeep.sheriker@microchip.com>2019-08-14 00:42:15 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2019-08-17 23:08:50 +0200
commit32d4e4226d7de48f0a156e7bc298667119405b84 (patch)
tree54dfd92b07d6a4ec4c40a506ec17cb364e067d1d /target/linux/at91
parent0b7c66c93b30ca43094bbb7bfff9b2eee9b63585 (diff)
downloadupstream-32d4e4226d7de48f0a156e7bc298667119405b84.tar.gz
upstream-32d4e4226d7de48f0a156e7bc298667119405b84.tar.bz2
upstream-32d4e4226d7de48f0a156e7bc298667119405b84.zip
at91: move at91-sdcard command to sama5.mk
Signed-off-by: Sandeep Sheriker M <sandeep.sheriker@microchip.com>
Diffstat (limited to 'target/linux/at91')
-rw-r--r--target/linux/at91/image/sama5.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index f9a190c8b2..d02f51a1db 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -6,6 +6,39 @@ define Device/default-nand
MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 2048
endef
+define Build/at91-sdcard
+ $(if $(findstring ext4,$@), \
+ rm -f $@.boot
+ mkfs.fat -C $@.boot $(FAT32_BLOCKS)
+
+ mcopy -i $@.boot $(KDIR)/zImage ::zImage
+
+ $(if $(findstring at91-sama5d27_som1_ek,$@), \
+ mcopy -i $@.boot \
+ $(BIN_DIR)/u-boot-$(DEVICE_NAME:at91-%=%)_mmc1/u-boot.bin \
+ ::u-boot.bin
+ mcopy -i $@.boot \
+ $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd1_uboot/at91bootstrap.bin \
+ ::BOOT.bin,
+ mcopy -i $@.boot \
+ $(BIN_DIR)/u-boot-$(DEVICE_NAME:at91-%=%)_mmc/u-boot.bin \
+ ::u-boot.bin
+ mcopy -i $@.boot \
+ $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd_uboot/at91bootstrap.bin \
+ ::BOOT.bin)
+
+ ./gen_at91_sdcard_img.sh \
+ $@.img \
+ $@.boot \
+ $(KDIR)/root.ext4 \
+ $(AT91_SD_BOOT_PARTSIZE) \
+ $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+
+ gzip -nc9 $@.img > $@
+
+ rm -f $@.img $@.boot )
+endef
+
define Device/at91-sama5d2_xplained
$(Device/evaluation-dtb)
DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 Xplained