aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/patches
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-18 13:35:46 +0000
committerJohn Crispin <john@openwrt.org>2015-02-18 13:35:46 +0000
commit4a6e4685884e4b9542ca660be7948d48810d8788 (patch)
treeb0393566cf1b93eb5b97e30931f429e78f3451e6 /target/linux/at91/patches
parentb2f666d0980e807486f612188dffbe4cd66f58bd (diff)
downloadupstream-4a6e4685884e4b9542ca660be7948d48810d8788.tar.gz
upstream-4a6e4685884e4b9542ca660be7948d48810d8788.tar.bz2
upstream-4a6e4685884e4b9542ca660be7948d48810d8788.zip
at91: bump to v3.18
Signed-off-by: Your Name <blogic@openwrt.org> SVN-Revision: 44489
Diffstat (limited to 'target/linux/at91/patches')
-rw-r--r--target/linux/at91/patches/100-ARM-at91-build-dtb-for-LMU5000.patch10
-rw-r--r--target/linux/at91/patches/805-free_some_portc_pins.patch11
-rw-r--r--target/linux/at91/patches/901-AT91-flexibity-default-leds-to-heartbeat.patch60
3 files changed, 81 insertions, 0 deletions
diff --git a/target/linux/at91/patches/100-ARM-at91-build-dtb-for-LMU5000.patch b/target/linux/at91/patches/100-ARM-at91-build-dtb-for-LMU5000.patch
new file mode 100644
index 0000000000..e8cc68d13d
--- /dev/null
+++ b/target/linux/at91/patches/100-ARM-at91-build-dtb-for-LMU5000.patch
@@ -0,0 +1,10 @@
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -26,6 +26,7 @@ dtb-$(CONFIG_ARCH_AT91) += usb_a9g20.dtb
+ dtb-$(CONFIG_ARCH_AT91) += usb_a9g20_lpw.dtb
+ # sam9g45
+ dtb-$(CONFIG_ARCH_AT91) += at91sam9m10g45ek.dtb
++dtb-$(CONFIG_ARCH_AT91) += lmu5000.dtb
+ dtb-$(CONFIG_ARCH_AT91) += pm9g45.dtb
+ # sam9n12
+ dtb-$(CONFIG_ARCH_AT91) += at91sam9n12ek.dtb
diff --git a/target/linux/at91/patches/805-free_some_portc_pins.patch b/target/linux/at91/patches/805-free_some_portc_pins.patch
new file mode 100644
index 0000000000..a9694d1f01
--- /dev/null
+++ b/target/linux/at91/patches/805-free_some_portc_pins.patch
@@ -0,0 +1,11 @@
+--- a/arch/arm/mach-at91/at91sam9260_devices.c
++++ b/arch/arm/mach-at91/at91sam9260_devices.c
+@@ -507,7 +507,7 @@ static struct platform_device at91sam926
+ .num_resources = ARRAY_SIZE(spi1_resources),
+ };
+
+-static const unsigned spi1_standard_cs[4] = { AT91_PIN_PB3, AT91_PIN_PC5, AT91_PIN_PC4, AT91_PIN_PC3 };
++static const unsigned spi1_standard_cs[2] = { AT91_PIN_PB3, AT91_PIN_PC5 };
+
+ void __init at91_add_device_spi(struct spi_board_info *devices, int nr_devices)
+ {
diff --git a/target/linux/at91/patches/901-AT91-flexibity-default-leds-to-heartbeat.patch b/target/linux/at91/patches/901-AT91-flexibity-default-leds-to-heartbeat.patch
new file mode 100644
index 0000000000..a97850ac91
--- /dev/null
+++ b/target/linux/at91/patches/901-AT91-flexibity-default-leds-to-heartbeat.patch
@@ -0,0 +1,60 @@
+--- a/arch/arm/mach-at91/board-flexibity.c
++++ b/arch/arm/mach-at91/board-flexibity.c
+@@ -89,49 +89,49 @@ static struct gpio_led flexibity_leds[]
+ .name = "usb1:green",
+ .gpio = AT91_PIN_PA12,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ },
+ {
+ .name = "usb1:red",
+ .gpio = AT91_PIN_PA13,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ },
+ {
+ .name = "usb2:green",
+ .gpio = AT91_PIN_PB26,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ },
+ {
+ .name = "usb2:red",
+ .gpio = AT91_PIN_PB27,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ },
+ {
+ .name = "usb3:green",
+ .gpio = AT91_PIN_PC8,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ },
+ {
+ .name = "usb3:red",
+ .gpio = AT91_PIN_PC6,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ },
+ {
+ .name = "usb4:green",
+ .gpio = AT91_PIN_PB4,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ },
+ {
+ .name = "usb4:red",
+ .gpio = AT91_PIN_PB5,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ }
+ };
+