aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/patches-3.14/700-tqma9263-support.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2014-09-03 03:10:18 +0000
committerFlorian Fainelli <florian@openwrt.org>2014-09-03 03:10:18 +0000
commit892d571d079e95179d50ad7424574e5752ece832 (patch)
treed8f98340a201f75bfaedd2827d09619cd9b26fb0 /target/linux/at91/patches-3.14/700-tqma9263-support.patch
parent035f68e8587800c5c9a9d2a7cbeb44a4afeb85e4 (diff)
downloadupstream-892d571d079e95179d50ad7424574e5752ece832.tar.gz
upstream-892d571d079e95179d50ad7424574e5752ece832.tar.bz2
upstream-892d571d079e95179d50ad7424574e5752ece832.zip
at91: add 3.14 support
Add support for Linux 3.14 for the Atmel's AT91 platform. Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 42414
Diffstat (limited to 'target/linux/at91/patches-3.14/700-tqma9263-support.patch')
-rw-r--r--target/linux/at91/patches-3.14/700-tqma9263-support.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/at91/patches-3.14/700-tqma9263-support.patch b/target/linux/at91/patches-3.14/700-tqma9263-support.patch
new file mode 100644
index 0000000000..fac71b43d6
--- /dev/null
+++ b/target/linux/at91/patches-3.14/700-tqma9263-support.patch
@@ -0,0 +1,29 @@
+Index: linux-3.14.16/arch/arm/mach-at91/Kconfig.non_dt
+===================================================================
+--- linux-3.14.16.orig/arch/arm/mach-at91/Kconfig.non_dt 2014-08-31 13:36:59.849640477 -0700
++++ linux-3.14.16/arch/arm/mach-at91/Kconfig.non_dt 2014-08-31 13:36:59.845640477 -0700
+@@ -281,6 +281,12 @@
+ Select this if you are using Atmel's AT91SAM9G10-EK Evaluation Kit.
+ <http://www.atmel.com/dyn/products/tools_card.asp?tool_id=4588>
+
++config MACH_TQMA9263
++ bool "TQ Components TQMa9263 board"
++ help
++ Select this if you are using the an TQ Components TQMa9263 board.
++ <http://www.tq-components.com/>
++
+ endif
+
+ # ----------------------------------------------------------
+Index: linux-3.14.16/arch/arm/mach-at91/Makefile
+===================================================================
+--- linux-3.14.16.orig/arch/arm/mach-at91/Makefile 2014-08-31 13:36:59.849640477 -0700
++++ linux-3.14.16/arch/arm/mach-at91/Makefile 2014-08-31 13:37:27.125639720 -0700
+@@ -62,6 +62,7 @@
+
+ # AT91SAM9263 board-specific support
+ obj-$(CONFIG_MACH_AT91SAM9263EK) += board-sam9263ek.o
++obj-$(CONFIG_MACH_TQMA9263) += board-tqma9263.o
+
+ # AT91SAM9RL board-specific support
+ obj-$(CONFIG_MACH_AT91SAM9RLEK) += board-sam9rlek.o