aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/modules.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-02-19 09:06:56 +0000
committerJohn Crispin <blogic@openwrt.org>2015-02-19 09:06:56 +0000
commit8c120014c194429122aa94fc0e9e59eff44ce296 (patch)
tree36e91178a649cdcebf3b6b86e3ddbf64ff65a6b7 /target/linux/at91/modules.mk
parent7f98a7666baeef20a2fec42abfa105a12f54ca17 (diff)
downloadupstream-8c120014c194429122aa94fc0e9e59eff44ce296.tar.gz
upstream-8c120014c194429122aa94fc0e9e59eff44ce296.tar.bz2
upstream-8c120014c194429122aa94fc0e9e59eff44ce296.zip
at91: USB gadget subsystem cleanup and driver fix.
Signed-off-by: Owen Kirby <osk@exegin.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44491 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/at91/modules.mk')
-rw-r--r--target/linux/at91/modules.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/at91/modules.mk b/target/linux/at91/modules.mk
index 7f98233eb5..6cfc3e4074 100644
--- a/target/linux/at91/modules.mk
+++ b/target/linux/at91/modules.mk
@@ -50,6 +50,24 @@ endef
$(eval $(call KernelPackage,at91-adc))
+define KernelPackage/at91-udc
+ SUBMENU:=$(USB_MENU)
+ TITLE:=USB Device Controller on atmel SoC
+ DEPENDS:=@TARGET_at91 +kmod-usb-gadget
+ KCONFIG:=CONFIG_USB_AT91
+ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/gadget/udc/at91_udc.ko),)
+ FILES:=$(LINUX_DIR)/drivers/usb/gadget/udc/at91_udc.ko
+else
+ FILES:=$(LINUX_DIR)/drivers/usb/gadget/at91_udc.ko
+endif
+ AUTOLOAD:=$(call AutoLoad,51,at91_udc)
+endef
+
+define KernelPackage/at91-adc/description
+ Kernel module to use the USB Device controller for Atmel AT91
+endef
+
+$(eval $(call KernelPackage,at91-udc))
I2C_AT91_MODULES:=\
CONFIG_I2C_AT91:drivers/i2c/busses/i2c-at91