aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91-2.6/image/Makefile
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2007-03-24 12:54:38 +0000
committerHamish Guthrie <hcg@openwrt.org>2007-03-24 12:54:38 +0000
commit535ff3f6b2edf6b21c10c584254459bf57fd0e8d (patch)
tree0bbeae6898d3f09fc06f07298c2336bf8e841810 /target/linux/at91-2.6/image/Makefile
parent7b564bfdcbef05f68d8a658caf832c6832705e1f (diff)
downloadupstream-535ff3f6b2edf6b21c10c584254459bf57fd0e8d.tar.gz
upstream-535ff3f6b2edf6b21c10c584254459bf57fd0e8d.tar.bz2
upstream-535ff3f6b2edf6b21c10c584254459bf57fd0e8d.zip
Added facility to program entire device from SD-Card Fixed up MAC address init in u-boot
SVN-Revision: 6662
Diffstat (limited to 'target/linux/at91-2.6/image/Makefile')
-rw-r--r--target/linux/at91-2.6/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/at91-2.6/image/Makefile b/target/linux/at91-2.6/image/Makefile
index 9a9948eaef..e3c77ab4e2 100644
--- a/target/linux/at91-2.6/image/Makefile
+++ b/target/linux/at91-2.6/image/Makefile
@@ -24,6 +24,7 @@ endef
define Image/Prepare
cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
cp $(KDIR)/romboot/romboot.bin $(KDIR)/romboot.bin
+ cp $(KDIR)/romboot/rbptest.bin $(KDIR)/rbptest.bin
cp $(KDIR)/u-boot-1.1.4/u-boot.bin $(KDIR)/u-boot.bin
dd if=$(KDIR)/u-boot.bin of=$(KDIR)/u-boot.block bs=100k count=1 conv=sync
cat $(KDIR)/u-boot.block $(KDIR)/params > $(KDIR)/u-boot.full
@@ -38,6 +39,7 @@ define Image/Build
dd if=$(KDIR)/root.squashfs of=$(KDIR)/root.block bs=1056k count=1 conv=sync
cat $(KDIR)/uImage.block $(KDIR)/root.block > $(KDIR)/knlroot.bin
$(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).trx -f $(KDIR)/romboot.bin -f$(KDIR)/u-boot.full -f$(KDIR)/knlroot.bin
+ cp $(KDIR)/rbptest.bin $(BIN_DIR)
$(call Image/Build/$(1),$(1))
endef