aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91-2.6/image/Makefile
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2007-03-20 09:59:17 +0000
committerHamish Guthrie <hcg@openwrt.org>2007-03-20 09:59:17 +0000
commit285c45e7fd7cb54f759b17b455a0c81b5ba78962 (patch)
tree879d568b02fafee9e4d0e10e8ba6f8f1b18d5d49 /target/linux/at91-2.6/image/Makefile
parentccb99d82df8463318b58e369af60a66b89e3c77e (diff)
downloadupstream-285c45e7fd7cb54f759b17b455a0c81b5ba78962.tar.gz
upstream-285c45e7fd7cb54f759b17b455a0c81b5ba78962.tar.bz2
upstream-285c45e7fd7cb54f759b17b455a0c81b5ba78962.zip
Added primary and secondary bootloaders
SVN-Revision: 6626
Diffstat (limited to 'target/linux/at91-2.6/image/Makefile')
-rw-r--r--target/linux/at91-2.6/image/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/target/linux/at91-2.6/image/Makefile b/target/linux/at91-2.6/image/Makefile
index 07660f2350..8b1a9476d7 100644
--- a/target/linux/at91-2.6/image/Makefile
+++ b/target/linux/at91-2.6/image/Makefile
@@ -5,16 +5,25 @@
# See /LICENSE for more information.
#
-TARGET_DEVICE_TABLE:=$(TOPDIR)/target/linux/vlink-2.6/image/device_table.txt
-
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
define Build/Clean
+ $(MAKE) -C romboot clean
+ $(MAKE) -C u-boot clean
+endef
+
+define Build/Compile
+ $(MAKE) -C romboot compile
+# $(MAKE) -C u-boot configure
+ $(MAKE) -C u-boot compile
endef
define Image/Prepare
cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
+ cp $(KDIR)/romboot/romboot.bin $(KDIR)/romboot.bin
+ cp $(KDIR)/u-boot-1.1.4/u-boot.bin $(KDIR)/u-boot.bin
+ cat $(KDIR)/romboot/romboot.block $(KDIR)/u-boot-1.1.4/u-boot.block > $(KDIR)/loaders.block
endef
define Image/BuildKernel
@@ -25,12 +34,4 @@ define Image/Build
$(call Image/Build/$(1),$(1))
endef
-define Image/Build/jffs2-64k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=65536 conv=sync
-endef
-
-define Image/Build/jffs2-128k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
-endef
-
$(eval $(call BuildImage))