aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/armvirt/image
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2017-04-18 20:59:52 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2017-04-23 09:19:33 +0800
commit88468f7e5307a132a612d619a73936d030339892 (patch)
tree6b60e75fbd89d8e0e293b687852c978cdef088b4 /target/linux/armvirt/image
parentb889d1e3cf0233e6efbf4b55197ab64aa8c0cd6a (diff)
downloadupstream-88468f7e5307a132a612d619a73936d030339892.tar.gz
upstream-88468f7e5307a132a612d619a73936d030339892.tar.bz2
upstream-88468f7e5307a132a612d619a73936d030339892.zip
armvirt: merge arm64 as subtarget 64
Original armvirt target is now subtarget 32. Other than that the built result should remain the same as before Besides old features already available with arm64, the new armvirt/64 subtarget will also have those features originally enabled for armvirt/32 with commit 44ecfc2 ("armvirt: new target") - pl011, uart - pl031, rtc - pl061, gpio - pci-host-generic - virtio_{mmio,pci,net,blk,scsi,9p,console,balloon} - smp with NR_CPUS=4 - cpu-hotplug - ext4 - DEBUG_BUGVERBOSE for debug purposes Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'target/linux/armvirt/image')
-rw-r--r--target/linux/armvirt/image/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/target/linux/armvirt/image/Makefile b/target/linux/armvirt/image/Makefile
index df4383f1d4..73d9145e0e 100644
--- a/target/linux/armvirt/image/Makefile
+++ b/target/linux/armvirt/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2016 Yousong Zhou <yszhou4tech@gmail.com>
+# Copyright (C) 2016-2017 Yousong Zhou <yszhou4tech@gmail.com>
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,11 +8,15 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
define Image/BuildKernel
- cp $(KDIR)/$(KERNELNAME) $(BIN_DIR)/$(IMG_PREFIX)-$(KERNELNAME)
+ $(foreach k,$(filter zImage Image,$(KERNELNAME)), \
+ cp $(KDIR)/$(KERNELNAME) $(BIN_DIR)/$(IMG_PREFIX)-$(k) \
+ )
endef
define Image/Build/Initramfs
- cp $(KDIR)/$(KERNELNAME)-initramfs $(BIN_DIR)/$(IMG_PREFIX)-$(KERNELNAME)-initramfs
+ $(foreach k,$(filter zImage Image,$(KERNELNAME)), \
+ cp $(KDIR)/$(k)-initramfs $(BIN_DIR)/$(IMG_PREFIX)-$(k)-initramfs \
+ )
endef
define Image/Build