aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/arm64/image/boot-wrapper/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2014-11-24 06:34:07 +0000
committerFlorian Fainelli <florian@openwrt.org>2014-11-24 06:34:07 +0000
commita2768bd9e0efb430e864fe5faf5070ea724e2797 (patch)
tree49fdd25cfab8faf7ab938fdd04da204fb43926cd /target/linux/arm64/image/boot-wrapper/Makefile
parentacf46919048fba514abf4d263e59e70eaddeb3ae (diff)
downloadupstream-a2768bd9e0efb430e864fe5faf5070ea724e2797.tar.gz
upstream-a2768bd9e0efb430e864fe5faf5070ea724e2797.tar.bz2
upstream-a2768bd9e0efb430e864fe5faf5070ea724e2797.zip
arm64: add ARM 64-bits target
This target can be emulated using ARM's Foundation_V8 simulator software or qemu-system-aarch64 using the command-line described in the README file. Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 43355
Diffstat (limited to 'target/linux/arm64/image/boot-wrapper/Makefile')
-rw-r--r--target/linux/arm64/image/boot-wrapper/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/target/linux/arm64/image/boot-wrapper/Makefile b/target/linux/arm64/image/boot-wrapper/Makefile
new file mode 100644
index 0000000000..cf58590545
--- /dev/null
+++ b/target/linux/arm64/image/boot-wrapper/Makefile
@@ -0,0 +1,38 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=aarch64-boot-wrapper
+PKG_VERSION:=2013-01-10
+PKG_RELEASE:=$(PKG_SOURCE_VERSION)
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://git.kernel.org/pub/scm/linux/kernel/git/cmarinas/boot-wrapper-aarch64.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=c51dde817b5ed5b8f741b67ac51bd67bd87b4a2a
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+PKG_MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+
+include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ KERNEL="../Image" \
+ DTC="$(LINUX_DIR)/scripts/dtc/dtc" \
+ FDT_SRC="$(LINUX_DIR)/arch/$(LINUX_KARCH)/boot/dts/foundation-v8.dts" \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
+ BOOTARGS="console=ttyAMA0 earlyprintk"
+endef
+
+define Build/InstallDev
+ $(CP) $(PKG_BUILD_DIR)/linux-system.axf $(KDIR)/linux-system.axf
+endef
+
+$(eval $(call Build/DefaultTargets))