aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/arm64/image/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-04-07 14:49:15 -0700
committerFlorian Fainelli <f.fainelli@gmail.com>2017-04-11 12:11:25 -0700
commitb319e304c8d394e44f45ca3ade9df0b3c880d1bd (patch)
tree4702f2c0040d10964592b83ed3998d045109feb7 /target/linux/arm64/image/Makefile
parentde5b8e5d2fe1fb43bad25dc13c7caf4158933eb5 (diff)
downloadupstream-b319e304c8d394e44f45ca3ade9df0b3c880d1bd.tar.gz
upstream-b319e304c8d394e44f45ca3ade9df0b3c880d1bd.tar.bz2
upstream-b319e304c8d394e44f45ca3ade9df0b3c880d1bd.zip
arm64: Remove Vexpress Foundation support
This required us to both download the Foundation emulator but also build a boot wrapper. QEMU is now fully usable and is a much better replacement. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'target/linux/arm64/image/Makefile')
-rw-r--r--target/linux/arm64/image/Makefile12
1 files changed, 0 insertions, 12 deletions
diff --git a/target/linux/arm64/image/Makefile b/target/linux/arm64/image/Makefile
index cc04b183fc..d52936808d 100644
--- a/target/linux/arm64/image/Makefile
+++ b/target/linux/arm64/image/Makefile
@@ -8,14 +8,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
define Image/Prepare
- -rm -rf $(KDIR)/linux-system.axf
cp $(LINUX_DIR)/arch/$(LINUX_KARCH)/boot/Image $(KDIR)/Image
- $(MAKE) -C boot-wrapper clean
- $(MAKE) -C boot-wrapper compile
-endef
-
-define Build/Clean
- $(MAKE) -C boot-wrapper clean
endef
define Image/Build/QemuVirt
@@ -25,13 +18,8 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
endif
endef
-define Image/Build/VexpressFoundation
- $(CP) $(KDIR)/linux-system.axf $(BIN_DIR)/$(IMG_PREFIX)-vexpress-foundation.axf
-endef
-
define Image/BuildKernel
$(call Image/Build/QemuVirt)
- $(call Image/Build/VexpressFoundation)
endef
define Image/Build/squashfs