aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/archs38
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-11 16:25:48 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-11 16:35:03 +0100
commitb9713ad6305c075c4388bce6cce7f5cb9bfe4104 (patch)
tree558d55c446279d71de7630d468852d66ec228f75 /target/linux/archs38
parent4ce3c416965e1d08728833cc7d074688041c163e (diff)
downloadupstream-b9713ad6305c075c4388bce6cce7f5cb9bfe4104.tar.gz
upstream-b9713ad6305c075c4388bce6cce7f5cb9bfe4104.tar.bz2
upstream-b9713ad6305c075c4388bce6cce7f5cb9bfe4104.zip
archs38: build dtb files in Image/Prepare so that they are available for Device/*
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/archs38')
-rw-r--r--target/linux/archs38/image/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/target/linux/archs38/image/Makefile b/target/linux/archs38/image/Makefile
index 62d5fb3e21..e9aac1f688 100644
--- a/target/linux/archs38/image/Makefile
+++ b/target/linux/archs38/image/Makefile
@@ -40,6 +40,13 @@ DEVICE_DTS_LIST:= axs103_idu nsim_hs_idu
FAT32_BLOCK_SIZE=1024
FAT32_BLOCKS=$(shell echo $$(($(CONFIG_AXS10X_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
+define Image/Prepare
+ # Build .dtb for all boards we may run on
+ $(foreach dts,$(DEVICE_DTS_LIST),
+ $(call Image/BuildDTB,$(DTS_DIR)/$(dts).dts,$(DTS_DIR)/$(dts).dtb)
+ )
+endef
+
define Image/Build/SDCard
rm -f $(KDIR_TMP)/$(IMG_PREFIX)-$(PROFILE)-boot.img
mkfs.fat $(KDIR_TMP)/$(IMG_PREFIX)-$(PROFILE)-boot.img -C $(FAT32_BLOCKS)
@@ -68,11 +75,6 @@ define Image/BuildKernel
$(KDIR)/vmlinux, \
$(BIN_DIR)/$(IMG_PREFIX)-uImage \
)
-
- # Build .dtb for all boards we may run on
- $(foreach dts,$(DEVICE_DTS_LIST),
- $(call Image/BuildDTB,$(DTS_DIR)/$(dts).dts,$(DTS_DIR)/$(dts).dtb)
- )
endef
define Image/Build