aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/archs38
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-11 11:17:13 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-11 13:02:41 +0100
commit3fa2c77e3a7b3becddfab5178341bef248547928 (patch)
tree41e096d395cdecb31717d69ee7aad2432e364349 /target/linux/archs38
parent889272d92db689fd9c910243635e44c9d8323095 (diff)
downloadupstream-3fa2c77e3a7b3becddfab5178341bef248547928.tar.gz
upstream-3fa2c77e3a7b3becddfab5178341bef248547928.tar.bz2
upstream-3fa2c77e3a7b3becddfab5178341bef248547928.zip
archs38: fix parallel build issue
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/archs38')
-rw-r--r--target/linux/archs38/image/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/target/linux/archs38/image/Makefile b/target/linux/archs38/image/Makefile
index 2ee805487d..62d5fb3e21 100644
--- a/target/linux/archs38/image/Makefile
+++ b/target/linux/archs38/image/Makefile
@@ -14,10 +14,6 @@ define Build/calculate-ep
$(eval KERNEL_ENTRY=$(shell $(KERNEL_CROSS)readelf -h $(1) | grep "Entry point address" | grep -o 0x.*))
endef
-define Build/build-dtb
- $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$(DTS_DIR)/$(DEVICE_DTS).dtb)
-endef
-
define Build/patch-dtb
$(STAGING_DIR_HOST)/bin/patch-dtb $@ $(DTS_DIR)/$(DEVICE_DTS).dtb
endef
@@ -26,7 +22,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
# Root FS built-in
define Device/vmlinux
KERNEL_SUFFIX := .elf
- KERNEL := kernel-bin | build-dtb | patch-dtb
+ KERNEL := kernel-bin | patch-dtb
KERNEL_INITRAMFS_NAME = vmlinux-initramfs.elf
endef
@@ -40,7 +36,7 @@ endif
# Root FS on SD-card
KERNEL_LOADADDR := 0x80000000
-DEVICE_DTS_LIST:= axs103_idu
+DEVICE_DTS_LIST:= axs103_idu nsim_hs_idu
FAT32_BLOCK_SIZE=1024
FAT32_BLOCKS=$(shell echo $$(($(CONFIG_AXS10X_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
@@ -74,7 +70,9 @@ define Image/BuildKernel
)
# Build .dtb for all boards we may run on
- $(foreach DEVICE_DTS,$(shell echo $(DEVICE_DTS_LIST)), $(call Build/build-dtb))
+ $(foreach dts,$(DEVICE_DTS_LIST),
+ $(call Image/BuildDTB,$(DTS_DIR)/$(dts).dts,$(DTS_DIR)/$(dts).dtb)
+ )
endef
define Image/Build