aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/arc770
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-11 16:25:32 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-11 16:35:03 +0100
commit90f0ca0ddca0da290b5b12c4d6c86458438edaa2 (patch)
treee621e74312db621a638d4637f155180b30496412 /target/linux/arc770
parentb9713ad6305c075c4388bce6cce7f5cb9bfe4104 (diff)
downloadupstream-90f0ca0ddca0da290b5b12c4d6c86458438edaa2.tar.gz
upstream-90f0ca0ddca0da290b5b12c4d6c86458438edaa2.tar.bz2
upstream-90f0ca0ddca0da290b5b12c4d6c86458438edaa2.zip
arc770: build dtb files in Image/Prepare so that they are available for Device/*
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/arc770')
-rw-r--r--target/linux/arc770/image/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/target/linux/arc770/image/Makefile b/target/linux/arc770/image/Makefile
index 4f8fbff29f..0f3de24ebc 100644
--- a/target/linux/arc770/image/Makefile
+++ b/target/linux/arc770/image/Makefile
@@ -40,6 +40,13 @@ DEVICE_DTS_LIST:= axs101 nsim_700
FAT32_BLOCK_SIZE=1024
FAT32_BLOCKS=$(shell echo $$(($(CONFIG_AXS10X_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
+define Image/Prepare
+ # Build .dtb for all boards we may run on
+ $(foreach dts,$(DEVICE_DTS_LIST),
+ $(call Image/BuildDTB,$(DTS_DIR)/$(dts).dts,$(DTS_DIR)/$(dts).dtb)
+ )
+endef
+
define Image/Build/SDCard
rm -f $(KDIR_TMP)/$(IMG_PREFIX)-$(PROFILE)-boot.img
mkfs.fat $(KDIR_TMP)/$(IMG_PREFIX)-$(PROFILE)-boot.img -C $(FAT32_BLOCKS)
@@ -68,11 +75,6 @@ define Image/BuildKernel
$(KDIR)/vmlinux, \
$(BIN_DIR)/$(IMG_PREFIX)-uImage \
)
-
- # Build .dtb for all boards we may run on
- $(foreach dts,$(DEVICE_DTS_LIST),
- $(call Image/BuildDTB,$(DTS_DIR)/$(dts).dts,$(DTS_DIR)/$(dts).dtb)
- )
endef
define Image/Build