aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/arc770
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-11 11:20:25 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-11 13:02:42 +0100
commit1b17f4f2609b822ce1225bb205794085072097c7 (patch)
treed9c7f76355c006aadc7c526ad88fae999e5b49e3 /target/linux/arc770
parent3fa2c77e3a7b3becddfab5178341bef248547928 (diff)
downloadupstream-1b17f4f2609b822ce1225bb205794085072097c7.tar.gz
upstream-1b17f4f2609b822ce1225bb205794085072097c7.tar.bz2
upstream-1b17f4f2609b822ce1225bb205794085072097c7.zip
arc770: fix parallel build issue
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/arc770')
-rw-r--r--target/linux/arc770/image/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/target/linux/arc770/image/Makefile b/target/linux/arc770/image/Makefile
index 3b124c2ba4..4f8fbff29f 100644
--- a/target/linux/arc770/image/Makefile
+++ b/target/linux/arc770/image/Makefile
@@ -14,10 +14,6 @@ define Build/calculate-ep
$(eval KERNEL_ENTRY=$(shell $(KERNEL_CROSS)readelf -h $(1) | grep "Entry point address" | grep -o 0x.*))
endef
-define Build/build-dtb
- $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$(DTS_DIR)/$(DEVICE_DTS).dtb)
-endef
-
define Build/patch-dtb
$(STAGING_DIR_HOST)/bin/patch-dtb $@ $(DTS_DIR)/$(DEVICE_DTS).dtb
endef
@@ -26,7 +22,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
# Root FS built-in
define Device/vmlinux
KERNEL_SUFFIX := .elf
- KERNEL := kernel-bin | build-dtb | patch-dtb
+ KERNEL := kernel-bin | patch-dtb
KERNEL_INITRAMFS_NAME = vmlinux-initramfs.elf
endef
@@ -40,7 +36,7 @@ endif
# Root FS on SD-card
KERNEL_LOADADDR := 0x80000000
-DEVICE_DTS_LIST:= axs101
+DEVICE_DTS_LIST:= axs101 nsim_700
FAT32_BLOCK_SIZE=1024
FAT32_BLOCKS=$(shell echo $$(($(CONFIG_AXS10X_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
@@ -74,7 +70,9 @@ define Image/BuildKernel
)
# Build .dtb for all boards we may run on
- $(foreach DEVICE_DTS,$(shell echo $(DEVICE_DTS_LIST)), $(call Build/build-dtb))
+ $(foreach dts,$(DEVICE_DTS_LIST),
+ $(call Image/BuildDTB,$(DTS_DIR)/$(dts).dts,$(DTS_DIR)/$(dts).dtb)
+ )
endef
define Image/Build