aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2017-02-04 17:41:42 +0100
committerJohn Crispin <john@phrozen.org>2017-02-09 09:45:27 +0100
commitf5416b0622b1496f8a164d85db0f1974858e30e8 (patch)
treec094c09e6e4707a47a0f7caf4693bc699988513b /target/linux/ar71xx
parentaab344d227e013dafdb820298f4dbb7c4e0524ba (diff)
downloadupstream-f5416b0622b1496f8a164d85db0f1974858e30e8.tar.gz
upstream-f5416b0622b1496f8a164d85db0f1974858e30e8.tar.bz2
upstream-f5416b0622b1496f8a164d85db0f1974858e30e8.zip
ar71xx: image: drop redundant CONSOLE assignment
Default CONSOLE value for ar71xx target is "ttyS0,115200", so there is no need to specify the same value in device profiles. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/generic.mk12
-rw-r--r--target/linux/ar71xx/image/nand.mk3
-rw-r--r--target/linux/ar71xx/image/ubnt.mk1
3 files changed, 0 insertions, 16 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 6e5a105a46..23847612c0 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -2,7 +2,6 @@ define Device/ap90q
DEVICE_TITLE := YunCore AP90Q
BOARDNAME = AP90Q
IMAGE_SIZE = 16000k
- CONSOLE = ttyS0,115200
MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env),16000k(firmware),64k(art)ro
endef
TARGET_DEVICES += ap90q
@@ -31,7 +30,6 @@ define Device/cf-e316n-v2
DEVICE_TITLE := COMFAST CF-E316N v2
BOARDNAME = CF-E316N-V2
IMAGE_SIZE = 16192k
- CONSOLE = ttyS0,115200
MTDPARTS = spi0.0:64k(u-boot)ro,64k(art)ro,16192k(firmware),64k(art-backup)ro
endef
TARGET_DEVICES += cf-e316n-v2
@@ -49,7 +47,6 @@ define Device/cf-e380ac-v1
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-ath10k ath10k-firmware-qca988x
BOARDNAME = CF-E380AC-V1
IMAGE_SIZE = 16128k
- CONSOLE = ttyS0,115200
MTDPARTS = spi0.0:128k(u-boot)ro,64k(art)ro,16128k(firmware),64k(art-backup)ro
endef
TARGET_DEVICES += cf-e380ac-v1
@@ -68,7 +65,6 @@ define Device/cf-e520n
DEVICE_PACKAGES := kmod-usb-core kmod-usb2
BOARDNAME = CF-E520N
IMAGE_SIZE = 8000k
- CONSOLE = ttyS0,115200
MTDPARTS = spi0.0:64k(u-boot)ro,64k(art)ro,8000k(firmware),64k(art-backup)ro
endef
TARGET_DEVICES += cf-e520n
@@ -93,7 +89,6 @@ define Device/cpe870
DEVICE_PACKAGES := rssileds
BOARDNAME = CPE870
IMAGE_SIZE = 7936k
- CONSOLE = ttyS0,115200
MTDPARTS = spi0.0:64k(u-boot)ro,64k(u-boot-env),7936k(firmware),64k(config)ro,64k(art)ro
endef
TARGET_DEVICES += cpe870
@@ -133,7 +128,6 @@ define Device/gl-ar300
DEVICE_PACKAGES := kmod-usb-core kmod-usb2
BOARDNAME = GL-AR300
IMAGE_SIZE = 16000k
- CONSOLE = ttyS0,115200
MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,16000k(firmware),64k(art)ro
endef
TARGET_DEVICES += gl-ar300
@@ -143,7 +137,6 @@ define Device/gl-ar300m
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 uboot-envtools
BOARDNAME = GL-AR300M
IMAGE_SIZE = 16000k
- CONSOLE = ttyS0,115200
MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env),16000k(firmware),64k(art)ro
endef
TARGET_DEVICES += gl-ar300m
@@ -480,7 +473,6 @@ define Device/sc1750
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
BOARDNAME = SC1750
IMAGE_SIZE = 15744k
- CONSOLE = ttyS0,115200
MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env),15744k(firmware),128k(APConfig),128k(kplog),64k(ART)
endef
TARGET_DEVICES += sc1750
@@ -490,7 +482,6 @@ define Device/sc300m
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
BOARDNAME = SC300M
IMAGE_SIZE = 15744k
- CONSOLE = ttyS0,115200
MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env),15744k(firmware),128k(APConfig),128k(kplog),64k(ART)
endef
TARGET_DEVICES += sc300m
@@ -500,7 +491,6 @@ define Device/sc450
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
BOARDNAME = SC450
IMAGE_SIZE = 15744k
- CONSOLE = ttyS0,115200
MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env),15744k(firmware),128k(APConfig),128k(kplog),64k(ART)
endef
TARGET_DEVICES += sc450
@@ -530,7 +520,6 @@ define Device/sr3200
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-ath10k ath10k-firmware-qca988x
BOARDNAME = SR3200
IMAGE_SIZE = 16000k
- CONSOLE = ttyS0,115200
MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env),16000k(firmware),64k(art)ro
endef
TARGET_DEVICES += sr3200
@@ -648,7 +637,6 @@ define Build/seama-seal
endef
define Device/seama
- CONSOLE := ttyS0,115200
LOADER_TYPE := bin
BLOCKSIZE := 64k
KERNEL := kernel-bin | patch-cmdline | relocate-kernel | lzma
diff --git a/target/linux/ar71xx/image/nand.mk b/target/linux/ar71xx/image/nand.mk
index e66014e663..2929662886 100644
--- a/target/linux/ar71xx/image/nand.mk
+++ b/target/linux/ar71xx/image/nand.mk
@@ -18,7 +18,6 @@ define Device/domywifi-dw33d
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage kmod-usb-ledtrig-usbport kmod-ath10k ath10k-firmware-qca988x
BOARDNAME = DW33D
IMAGE_SIZE = 16000k
- CONSOLE = ttyS0,115200
MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,14528k(rootfs),1472k(kernel),64k(art)ro,16000k@0x50000(firmware);ar934x-nfc:96m(rootfs_data),32m(backup)ro
IMAGE/sysupgrade.bin = append-rootfs | pad-rootfs | pad-to 14528k | append-kernel | check-size $$$$(IMAGE_SIZE)
endef
@@ -37,7 +36,6 @@ define Device/mr18
DEVICE_PACKAGES := kmod-spi-gpio kmod-ath9k
BOARDNAME = MR18
BLOCKSIZE := 64k
- CONSOLE = ttyS0,115200
MTDPARTS = ar934x-nfc:512k(nandloader)ro,8M(kernel),8M(recovery),113664k(ubi),128k@130944k(odm-caldata)ro
IMAGES := sysupgrade.tar
KERNEL := kernel-bin | patch-cmdline | MerakiNAND
@@ -59,7 +57,6 @@ define Device/z1
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-spi-gpio kmod-ath9k kmod-owl-loader
BOARDNAME = Z1
BLOCKSIZE := 64k
- CONSOLE = ttyS0,115200
MTDPARTS = ar934x-nfc:128K(loader1)ro,8064K(kernel),128K(loader2)ro,8064K(recovery),114560K(ubi),128K(origcaldata)ro
IMAGES := sysupgrade.tar
KERNEL := kernel-bin | patch-cmdline | MerakiNAND-old
diff --git a/target/linux/ar71xx/image/ubnt.mk b/target/linux/ar71xx/image/ubnt.mk
index 68fe8ad301..7a1fc80dea 100644
--- a/target/linux/ar71xx/image/ubnt.mk
+++ b/target/linux/ar71xx/image/ubnt.mk
@@ -193,7 +193,6 @@ define Device/ubnt-air-gateway-pro
BOARDNAME := UBNT-AGWP
UBNT_TYPE := AirGWP
UBNT_CHIP := ar934x
- CONSOLE = ttyS0,115200
endef
TARGET_DEVICES += ubnt-air-gateway-pro