aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-05-08 20:06:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-05-08 20:06:44 +0000
commitf4c9a4e042328fcc53a7489991605a6715dc2d1c (patch)
treed241ed57e1c94f348167ccb9df33e188105da47a /target/linux/ar71xx
parent61c07602d5a4064697317fa8fb3c18f8e56acd71 (diff)
downloadupstream-f4c9a4e042328fcc53a7489991605a6715dc2d1c.tar.gz
upstream-f4c9a4e042328fcc53a7489991605a6715dc2d1c.tar.bz2
upstream-f4c9a4e042328fcc53a7489991605a6715dc2d1c.zip
ar71xx: use the lzma kernel and a proper size limit for pb92
SVN-Revision: 21405
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index c6721de48e..942ef12082 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -212,14 +212,16 @@ define Image/Build/AP83
endef
define Image/Build/PB92
- $(call PatchKernelGzip,$(2),$(3))
- if [ `stat -c%s $(KDIR)/root.$(1)` -gt 2818048 ]; then \
+ $(call PatchKernelLzma,$(2),$(3))
+ if [ `stat -c%s $(KDIR)/vmlinux-$(2).bin.lzma` -gt 917504 ]; then \
+ echo "Warning: $(KDIR)/vmlinux-$(2).bin.lzma is too big"; \
+ elif [ `stat -c%s $(KDIR)/root.$(1)` -gt 2818048 ]; then \
echo "Warning: $(KDIR)/root.$(1) is too big"; \
else \
- mkimage -A mips -O linux -T kernel -a 0x80060000 -C gzip -e \
+ mkimage -A mips -O linux -T kernel -a 0x80060000 -C lzma -e \
0x80060000 \
-n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
- -d $(KDIR)/vmlinux-$(2).bin.gz \
+ -d $(KDIR)/vmlinux-$(2).bin.lzma \
$(KDIR)/vmlinux-$(2).uImage; \
dd if=$(KDIR)/vmlinux-$(2).uImage \
of=$(call imgname,kernel,$(2)).bin bs=64k conv=sync; \