aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-06-06 00:27:42 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-06-06 22:27:59 +0200
commit7128fe094f25e91ed408acf727a13d85edc3041e (patch)
tree6de1cbe39f3ddce93cf8ad896f8931394c07882b /target/linux/ar71xx
parente5301885bc9772f0e5ca5b3870b2c43824e12546 (diff)
downloadupstream-7128fe094f25e91ed408acf727a13d85edc3041e.tar.gz
upstream-7128fe094f25e91ed408acf727a13d85edc3041e.tar.bz2
upstream-7128fe094f25e91ed408acf727a13d85edc3041e.zip
ar71xx: lzma-loader: set page size to 4KB
The text section in the ELF loader is aligned to the maximum page size, which defaults to 64KB. Reduce it to the actual page size to avoid wasting flash space for this alignment. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/lzma-loader/src/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/lzma-loader/src/Makefile b/target/linux/ar71xx/image/lzma-loader/src/Makefile
index c54f64a550..7773f027a2 100644
--- a/target/linux/ar71xx/image/lzma-loader/src/Makefile
+++ b/target/linux/ar71xx/image/lzma-loader/src/Makefile
@@ -97,7 +97,7 @@ loader2.o: loader.bin
$(LD) -r -b binary --oformat $(O_FORMAT) -o $@ $<
loader.elf: loader2.o
- $(LD) -e startup -T loader2.lds -Ttext $(LOADADDR) -o $@ $<
+ $(LD) -z max-page-size=0x1000 -e startup -T loader2.lds -Ttext $(LOADADDR) -o $@ $<
mrproper: clean