aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2016-11-23 16:34:31 +0100
committerMathias Kresin <dev@kresin.me>2016-11-24 22:37:40 +0100
commit6998b8a054a48a598cf961c785f311c6f71408cd (patch)
treef4e0b306e25a9faa23315a520aaf94c17d70b533 /target/linux/ar71xx
parentae79c41286f0d9a97f2641450240ecac5465677d (diff)
downloadupstream-6998b8a054a48a598cf961c785f311c6f71408cd.tar.gz
upstream-6998b8a054a48a598cf961c785f311c6f71408cd.tar.bz2
upstream-6998b8a054a48a598cf961c785f311c6f71408cd.zip
ar71xx: move DomyWifi DW33D to nand subtarget
This device uses NAND FLASH, so it should be kept in nand subtarget. Also, inlcude in packages kmod-usb-ledtrig-usbport instead of obsolete kmod-ledtrig-usbdev. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt4
-rw-r--r--target/linux/ar71xx/image/generic.mk11
-rw-r--r--target/linux/ar71xx/image/nand.mk11
3 files changed, 11 insertions, 15 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 001edbeb17..f1bfcb80a4 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -562,10 +562,6 @@ config ATH79_MACH_DOMYWIFI_DW33D
select ATH79_DEV_NFC
select ATH79_DEV_WMAC
select ATH79_DEV_USB
- select MTD_NAND
- select MTD_NAND_ECC
- select MTD_NAND_AR934X
- select MTD_NAND_AR934X_HW_ECC
config ATH79_MACH_DR344
bool "Wallys DR344 board support"
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 331509a15a..6ceabeb288 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -98,17 +98,6 @@ define Device/cpe870
endef
TARGET_DEVICES += cpe870
-define Device/domywifi-dw33d
- DEVICE_TITLE := DomyWifi DW33D
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage kmod-ledtrig-usbdev kmod-ath10k
- BOARDNAME = DW33D
- IMAGE_SIZE = 16000k
- CONSOLE = ttyS0,115200
- MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,14528k(rootfs),1472k(kernel),64k(art)ro,16000k@0x50000(firmware);ar934x-nfc:96m(rootfs_data),32m(backup)ro
- IMAGE/sysupgrade.bin = append-rootfs | pad-rootfs | pad-to 14528k | append-kernel | check-size $$$$(IMAGE_SIZE)
-endef
-TARGET_DEVICES += domywifi-dw33d
-
define Device/dragino2
BOARDNAME := DRAGINO2
CONSOLE := ttyATH0,115200
diff --git a/target/linux/ar71xx/image/nand.mk b/target/linux/ar71xx/image/nand.mk
index aa43a91ee9..cf4c286bee 100644
--- a/target/linux/ar71xx/image/nand.mk
+++ b/target/linux/ar71xx/image/nand.mk
@@ -13,6 +13,17 @@ endef
TARGET_DEVICES += c-60
+define Device/domywifi-dw33d
+ DEVICE_TITLE := DomyWifi DW33D
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage kmod-usb-ledtrig-usbport kmod-ath10k
+ BOARDNAME = DW33D
+ IMAGE_SIZE = 16000k
+ CONSOLE = ttyS0,115200
+ MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,14528k(rootfs),1472k(kernel),64k(art)ro,16000k@0x50000(firmware);ar934x-nfc:96m(rootfs_data),32m(backup)ro
+ IMAGE/sysupgrade.bin = append-rootfs | pad-rootfs | pad-to 14528k | append-kernel | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += domywifi-dw33d
+
define Build/MerakiNAND
-$(STAGING_DIR_HOST)/bin/mkmerakifw \
-B $(BOARDNAME) -s \