aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorHenryk Heisig <hyniu@o2.pl>2016-11-14 21:55:25 +0100
committerJohn Crispin <john@phrozen.org>2016-11-16 11:01:18 +0100
commit0d760bfba8da81c508ec1cec679c85278820bba7 (patch)
tree0335974448a5be148807c95b284ace595897b683 /target/linux/ar71xx
parent5aace5a5fbcf4a80c6765b605ffdd86d2cfadfb0 (diff)
downloadupstream-0d760bfba8da81c508ec1cec679c85278820bba7.tar.gz
upstream-0d760bfba8da81c508ec1cec679c85278820bba7.tar.bz2
upstream-0d760bfba8da81c508ec1cec679c85278820bba7.zip
ar71xx: tl-wpa8630: Use dynamic parsing of the firmware partition
Signed-off-by: Henryk Heisig <hyniu@o2.pl>
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata2
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wpa8630.c8
-rw-r--r--target/linux/ar71xx/image/tp-link.mk2
3 files changed, 8 insertions, 4 deletions
diff --git a/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index 872e6a8427..bbb28ed74d 100644
--- a/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -87,7 +87,7 @@ case "$FIRMWARE" in
ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +16)
;;
tl-wpa8630)
- ath10kcal_extract "ART" 20480 2116
+ ath10kcal_extract "art" 20480 2116
ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +1)
;;
unifiac-lite | \
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wpa8630.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wpa8630.c
index acdd7c3bb9..0a1e6b4d91 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wpa8630.c
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wpa8630.c
@@ -40,8 +40,14 @@
#define TL_WPA8630_WMAC_CALDATA_OFFSET 0x1000
#define TL_WPA8630_PCI_CALDATA_OFFSET 0x5000
+static const char *tl_wpa8630_part_probes[] = {
+ "tp-link-64k",
+ NULL,
+};
+
static struct flash_platform_data tl_wpa8630_flash_data = {
- .type = "s25fl064k",
+ .part_probes = tl_wpa8630_part_probes,
+ .type = "s25fl064k",
};
static struct gpio_led tl_wpa8630_leds_gpio[] __initdata = {
diff --git a/target/linux/ar71xx/image/tp-link.mk b/target/linux/ar71xx/image/tp-link.mk
index d04bac15be..4c2ce18e10 100644
--- a/target/linux/ar71xx/image/tp-link.mk
+++ b/target/linux/ar71xx/image/tp-link.mk
@@ -378,8 +378,6 @@ define Device/tl-wpa8630
BOARDNAME := TL-WPA8630
DEVICE_PROFILE := TL-WPA8630
TPLINK_HWID := 0x86300001
- MTDPARTS = spi0.0:64k(u-boot)ro,1344k(kernel),6656k(rootfs),64k(mib0)ro,64k(ART)ro,8000k@0x10000(firmware)
- IMAGE/sysupgrade.bin := append-rootfs | mktplinkfw sysupgrade -a 0x10000
endef
TARGET_DEVICES += tl-wpa8630