aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/profiles
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-04-18 16:24:12 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-04-18 16:24:12 +0000
commit693ea524c1a2c69031c8b4b9a4896a062c142c73 (patch)
treec8c4f42f8cb1ff69ddb773d2e803ee87b4f7ca3e /target/linux/ar71xx/profiles
parent8d86dbb4541aa050c072bb88cc8b137365ba18c6 (diff)
downloadupstream-693ea524c1a2c69031c8b4b9a4896a062c142c73.tar.gz
upstream-693ea524c1a2c69031c8b4b9a4896a062c142c73.tar.bz2
upstream-693ea524c1a2c69031c8b4b9a4896a062c142c73.zip
ar71xx: adding support for zyxel nbg460n/550n/550nh boards
This patch adds support for the zyxel nbg460n/550n/550nh routers. Currently this only works if a second stage bootloader is also flashed, as the used switch needs extra initialization. Signed-off-by: Michael Kurz <michi.kurz@googlemail.com> SVN-Revision: 20990
Diffstat (limited to 'target/linux/ar71xx/profiles')
-rw-r--r--target/linux/ar71xx/profiles/zyxel.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ar71xx/profiles/zyxel.mk b/target/linux/ar71xx/profiles/zyxel.mk
new file mode 100644
index 0000000000..73ae4e224c
--- /dev/null
+++ b/target/linux/ar71xx/profiles/zyxel.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NBG_460N_550N_550NH
+ NAME:=Zyxel NBG 460N/550N/550NH
+ PACKAGES:=kmod-ath9k swconfig
+endef
+
+define Profile/NBG_460N_550N_550NH/Description
+ Package set optimized for the Zyxel NBG 460N/550N/550NH Routers.
+endef
+
+$(eval $(call Profile,NBG_460N_550N_550NH))