aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.1
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-08-17 06:16:54 +0000
committerJohn Crispin <john@openwrt.org>2015-08-17 06:16:54 +0000
commit4463bc017beba6be6c484f0ff5e9d381debafe38 (patch)
treef81909ba8f3ca67b7e791e950431ff609ccb1dc5 /target/linux/ar71xx/patches-4.1
parent9b0516c9fc993745cab983e9ada3e4b00185855c (diff)
downloadupstream-4463bc017beba6be6c484f0ff5e9d381debafe38.tar.gz
upstream-4463bc017beba6be6c484f0ff5e9d381debafe38.tar.bz2
upstream-4463bc017beba6be6c484f0ff5e9d381debafe38.zip
ar71xx: Add support for Black Swift
Add support for the Black Swift board: http://www.black-swift.com/ Took relevant parts and slightly adapted from: https://github.com/blackswift/openwrt/blob/master/bsb.patch Signed-off-by: Bruno Randolf <br1@einfach.org> SVN-Revision: 46651
Diffstat (limited to 'target/linux/ar71xx/patches-4.1')
-rw-r--r--target/linux/ar71xx/patches-4.1/814-MIPS-ath79-add-blackswift.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-4.1/814-MIPS-ath79-add-blackswift.patch b/target/linux/ar71xx/patches-4.1/814-MIPS-ath79-add-blackswift.patch
new file mode 100644
index 0000000000..6ec2a8f154
--- /dev/null
+++ b/target/linux/ar71xx/patches-4.1/814-MIPS-ath79-add-blackswift.patch
@@ -0,0 +1,45 @@
+Index: linux-4.1.4/arch/mips/ath79/Kconfig
+===================================================================
+--- linux-4.1.4.orig/arch/mips/ath79/Kconfig 2015-08-10 16:28:12.409834069 +0100
++++ linux-4.1.4/arch/mips/ath79/Kconfig 2015-08-10 16:30:16.341831945 +0100
+@@ -904,6 +904,16 @@
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+
++config ATH79_MACH_BSB
++ bool "Smart Electronics Black Swift board"
++ select SOC_AR933X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++
+ config ATH79_MACH_ARCHER_C7
+ bool "TP-LINK Archer C5/C7/TL-WDR4900 v2 board support"
+ select SOC_QCA955X
+Index: linux-4.1.4/arch/mips/ath79/Makefile
+===================================================================
+--- linux-4.1.4.orig/arch/mips/ath79/Makefile 2015-08-10 16:28:12.409834069 +0100
++++ linux-4.1.4/arch/mips/ath79/Makefile 2015-08-10 16:30:39.985831540 +0100
+@@ -56,6 +56,7 @@
+ obj-$(CONFIG_ATH79_MACH_ARCHER_C7) += mach-archer-c7.o
+ obj-$(CONFIG_ATH79_MACH_AW_NR580) += mach-aw-nr580.o
+ obj-$(CONFIG_ATH79_MACH_BHU_BXU2000N2_A)+= mach-bhu-bxu2000n2-a.o
++obj-$(CONFIG_ATH79_MACH_BSB) += mach-bsb.o
+ obj-$(CONFIG_ATH79_MACH_CAP4200AG) += mach-cap4200ag.o
+ obj-$(CONFIG_ATH79_MACH_CPE510) += mach-cpe510.o
+ obj-$(CONFIG_ATH79_MACH_DB120) += mach-db120.o
+Index: linux-4.1.4/arch/mips/ath79/machtypes.h
+===================================================================
+--- linux-4.1.4.orig/arch/mips/ath79/machtypes.h 2015-08-10 16:28:12.409834069 +0100
++++ linux-4.1.4/arch/mips/ath79/machtypes.h 2015-08-10 16:31:13.693830962 +0100
+@@ -39,6 +39,7 @@
+ ATH79_MACH_ARCHER_C7, /* TP-LINK Archer C7 board */
+ ATH79_MACH_AW_NR580, /* AzureWave AW-NR580 */
+ ATH79_MACH_BHU_BXU2000N2_A1, /* BHU BXU2000n-2 A1 */
++ ATH79_MACH_BSB, /* Smart Electronics Black Swift board */
+ ATH79_MACH_CAP4200AG, /* Senao CAP4200AG */
+ ATH79_MACH_CARAMBOLA2, /* 8devices Carambola2 */
+ ATH79_MACH_CPE510, /* TP-LINK CPE510 */