aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.14/500-MIPS-fw-myloader.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2018-08-09 15:59:41 +0200
committerJohn Crispin <john@phrozen.org>2018-08-22 08:09:00 +0200
commit318e19ba6755105bb6cc19937d8fff26cbd2cc6f (patch)
tree2f7c96140932a2770fb767141c7d1e93d29127b0 /target/linux/ar71xx/patches-4.14/500-MIPS-fw-myloader.patch
parente5f56c07d7fab9a6f2201f4100b593349b8ef67d (diff)
downloadupstream-318e19ba6755105bb6cc19937d8fff26cbd2cc6f.tar.gz
upstream-318e19ba6755105bb6cc19937d8fff26cbd2cc6f.tar.bz2
upstream-318e19ba6755105bb6cc19937d8fff26cbd2cc6f.zip
ar71xx: add v4.14 support
adds v4.14 patches for testing but leaves v4.9 as default for now. Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ar71xx/patches-4.14/500-MIPS-fw-myloader.patch')
-rw-r--r--target/linux/ar71xx/patches-4.14/500-MIPS-fw-myloader.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-4.14/500-MIPS-fw-myloader.patch b/target/linux/ar71xx/patches-4.14/500-MIPS-fw-myloader.patch
new file mode 100644
index 0000000000..304fd69b22
--- /dev/null
+++ b/target/linux/ar71xx/patches-4.14/500-MIPS-fw-myloader.patch
@@ -0,0 +1,22 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -218,6 +218,7 @@ cflags-$(toolchain-virt) += -DTOOLCHAIN
+ #
+ libs-$(CONFIG_FW_ARC) += arch/mips/fw/arc/
+ libs-$(CONFIG_FW_CFE) += arch/mips/fw/cfe/
++libs-$(CONFIG_MYLOADER) += arch/mips/fw/myloader/
+ libs-$(CONFIG_FW_SNIPROM) += arch/mips/fw/sni/
+ libs-y += arch/mips/fw/lib/
+
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -1150,6 +1150,9 @@ config MIPS_MSC
+ config MIPS_NILE4
+ bool
+
++config MYLOADER
++ bool
++
+ config SYNC_R4K
+ bool
+