aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.3/435-spi-vsc7385_driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-02-10 11:53:56 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-02-10 11:53:56 +0000
commit32a18a05f8998202a4ea55030853571a46de2dc0 (patch)
tree16f1ca2a2fc1a9334b40b0cd8f59639263ee0c27 /target/linux/ar71xx/patches-3.3/435-spi-vsc7385_driver.patch
parent512df38f5cb2b9a34b71ec674a4ae9bf2e769597 (diff)
downloadupstream-32a18a05f8998202a4ea55030853571a46de2dc0.tar.gz
upstream-32a18a05f8998202a4ea55030853571a46de2dc0.tar.bz2
upstream-32a18a05f8998202a4ea55030853571a46de2dc0.zip
ar71xx: add preliminary support for 3.3
SVN-Revision: 30410
Diffstat (limited to 'target/linux/ar71xx/patches-3.3/435-spi-vsc7385_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-3.3/435-spi-vsc7385_driver.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.3/435-spi-vsc7385_driver.patch b/target/linux/ar71xx/patches-3.3/435-spi-vsc7385_driver.patch
new file mode 100644
index 0000000000..14626879b3
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.3/435-spi-vsc7385_driver.patch
@@ -0,0 +1,23 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -454,6 +454,11 @@ config SPI_RB4XX_CPLD
+ SPI driver for the Xilinx CPLD chip present on the
+ MikroTik RB4xx boards.
+
++config SPI_VSC7385
++ tristate "Vitesse VSC7385 ethernet switch driver"
++ help
++ SPI driver for the Vitesse VSC7385 ethernet switch.
++
+ #
+ # Add new SPI protocol masters in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -61,5 +61,5 @@ obj-$(CONFIG_SPI_TI_SSP) += spi-ti-ssp.
+ obj-$(CONFIG_SPI_TLE62X0) += spi-tle62x0.o
+ obj-$(CONFIG_SPI_TOPCLIFF_PCH) += spi-topcliff-pch.o
+ obj-$(CONFIG_SPI_TXX9) += spi-txx9.o
++obj-$(CONFIG_SPI_VSC7385) += spi-vsc7385.o
+ obj-$(CONFIG_SPI_XILINX) += spi-xilinx.o
+-