aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.10
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-07-13 18:21:04 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-07-13 18:21:04 +0000
commit4304f21da11dbcdb985c57c0ea93c19f067c55a9 (patch)
tree5dc26cf62044d8d34b761c2d9cc30557297707b0 /target/linux/ar71xx/patches-3.10
parent7170324f7780bc2b2bdfb1abe5d192b65d29c25e (diff)
downloadupstream-4304f21da11dbcdb985c57c0ea93c19f067c55a9.tar.gz
upstream-4304f21da11dbcdb985c57c0ea93c19f067c55a9.tar.bz2
upstream-4304f21da11dbcdb985c57c0ea93c19f067c55a9.zip
ar71xx: add kernel support for GL-Inet V1 boards/routers
The GL-Connect GL.iNet v1 router is basically a TP-Link TL-WR703N with more DRAM/Flash, 2x Ethernet ports and console/GPIO header in the same small form-factor: <http://www.gl-inet.com/w/?lang=en> Moreover, the manufacturer is promoting the OpenWrt usage to replace the original firmware and proposing patches against both AA and trunk: <http://www.gl-inet.com/w/?p=398&lang=en> This is a clean up of the original manufacturer GPLv2 patch by alzhao, proposed to the list by Mark Janssen. Signed-off-by: Michel Stempin <michel.stempin@wanadoo.fr> Signed-off-by: Mark Janssen <mark@sig-io.nl> Signed-off-by: alzhao <alzhao@gmail.com> Patchwork: http://patchwork.openwrt.org/patch/5273/ [juhosg: - remove user-space and image generation support, will be included from other patches, - fix coding style and drop superfluous comment in mach-gl-inet.c, - rename and refresh kernel patch, - adjust subject] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41618 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.10')
-rw-r--r--target/linux/ar71xx/patches-3.10/717-MIPS-ath79-add-gl-inet-v1-support.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.10/717-MIPS-ath79-add-gl-inet-v1-support.patch b/target/linux/ar71xx/patches-3.10/717-MIPS-ath79-add-gl-inet-v1-support.patch
new file mode 100644
index 0000000000..d85ad2319a
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.10/717-MIPS-ath79-add-gl-inet-v1-support.patch
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -357,6 +357,16 @@ config ATH79_MACH_EL_MINI
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
++config ATH79_MACH_GL_INET
++ bool "GL-INET support"
++ select SOC_AR933X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++
+ config ATH79_MACH_GS_OOLITE
+ bool "GS Oolite V1 support"
+ select SOC_AR933X
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -52,6 +52,7 @@ enum ath79_mach_type {
+ ATH79_MACH_EAP7660D, /* Senao EAP7660D */
+ ATH79_MACH_EL_M150, /* EasyLink EL-M150 */
+ ATH79_MACH_EL_MINI, /* EasyLink EL-MINI */
++ ATH79_MACH_GL_INET, /* GL-CONNECT GL-INET */
+ ATH79_MACH_GS_OOLITE, /* GS OOLITE V1.0 */
+ ATH79_MACH_HIWIFI_HC6361, /* HiWiFi HC6361 */
+ ATH79_MACH_JA76PF, /* jjPlus JA76PF */
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -64,6 +64,7 @@ obj-$(CONFIG_ATH79_MACH_EW_DORIN) += mac
+ obj-$(CONFIG_ATH79_MACH_EAP7660D) += mach-eap7660d.o
+ obj-$(CONFIG_ATH79_MACH_EL_M150) += mach-el-m150.o
+ obj-$(CONFIG_ATH79_MACH_EL_MINI) += mach-el-mini.o
++obj-$(CONFIG_ATH79_MACH_GL_INET) += mach-gl-inet.o
+ obj-$(CONFIG_ATH79_MACH_GS_OOLITE) += mach-gs-oolite.o
+ obj-$(CONFIG_ATH79_MACH_HIWIFI_HC6361) += mach-hiwifi-hc6361.o
+ obj-$(CONFIG_ATH79_MACH_JA76PF) += mach-ja76pf.o