aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.10/702-MIPS-ath79-add-MyNet-N750-support.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-12-16 07:16:42 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-12-16 07:16:42 +0000
commit31d7d99e60fed8212c2379cad7141179e6eff4dc (patch)
treed891e60772f8350abe6784bef16e41fad62c126f /target/linux/ar71xx/patches-3.10/702-MIPS-ath79-add-MyNet-N750-support.patch
parent09fb8ac34c6f7bc427e83597600f91de766bd003 (diff)
downloadupstream-31d7d99e60fed8212c2379cad7141179e6eff4dc.tar.gz
upstream-31d7d99e60fed8212c2379cad7141179e6eff4dc.tar.bz2
upstream-31d7d99e60fed8212c2379cad7141179e6eff4dc.zip
ar71xx: add kernel support for WD My Net N750
Signed-off-by: Felix Kaechele <heffer@fedoraproject.org> [juhosg: use a separate patch for kernel changes] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39077 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-3.10/702-MIPS-ath79-add-MyNet-N750-support.patch')
-rw-r--r--target/linux/ar71xx/patches-3.10/702-MIPS-ath79-add-MyNet-N750-support.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.10/702-MIPS-ath79-add-MyNet-N750-support.patch b/target/linux/ar71xx/patches-3.10/702-MIPS-ath79-add-MyNet-N750-support.patch
new file mode 100644
index 0000000000..95fb687ea1
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.10/702-MIPS-ath79-add-MyNet-N750-support.patch
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -56,6 +56,7 @@ enum ath79_mach_type {
+ ATH79_MACH_MR600V2, /* OpenMesh MR600v2 */
+ ATH79_MACH_MR600, /* OpenMesh MR600 */
+ ATH79_MACH_MYNET_N600, /* WD My Net N600 */
++ ATH79_MACH_MYNET_N750, /* WD My Net N750 */
+ ATH79_MACH_MYNET_REXT, /* WD My Net Wi-Fi Range Extender */
+ ATH79_MACH_MZK_W04NU, /* Planex MZK-W04NU */
+ ATH79_MACH_MZK_W300NH, /* Planex MZK-W300NH */
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -820,6 +820,16 @@ config ATH79_MACH_MYNET_N600
+ select ATH79_DEV_WMAC
+ select ATH79_NVRAM
+
++config ATH79_MACH_MYNET_N750
++ bool "WD My Net N750 board support"
++ select SOC_AR934X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_WMAC
++ select ATH79_NVRAM
++
+ config ATH79_MACH_MYNET_REXT
+ bool "WD My Net Wi-Fi Range Extender board support"
+ select SOC_AR934X
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -67,6 +67,7 @@ obj-$(CONFIG_ATH79_MACH_JWAP003) += mach
+ obj-$(CONFIG_ATH79_MACH_HORNET_UB) += mach-hornet-ub.o
+ obj-$(CONFIG_ATH79_MACH_MR600) += mach-mr600.o
+ obj-$(CONFIG_ATH79_MACH_MYNET_N600) += mach-mynet-n600.o
++obj-$(CONFIG_ATH79_MACH_MYNET_N750) += mach-mynet-n750.o
+ obj-$(CONFIG_ATH79_MACH_MYNET_REXT) += mach-mynet-rext.o
+ obj-$(CONFIG_ATH79_MACH_MZK_W04NU) += mach-mzk-w04nu.o
+ obj-$(CONFIG_ATH79_MACH_MZK_W300NH) += mach-mzk-w300nh.o