aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.10/632-MIPS-ath79-add-MyNet-Wifi-Range-Extender-support.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-11-07 22:31:52 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-11-07 22:31:52 +0000
commitece1323ed43aa8549d38ba123ca0ad88b95fa7f0 (patch)
tree7d3e2f00ff7740c9f111a0ee7803ba11d55bb3ec /target/linux/ar71xx/patches-3.10/632-MIPS-ath79-add-MyNet-Wifi-Range-Extender-support.patch
parent5a85a21e061772188f4a3cdc76d451d98cc8ae57 (diff)
downloadupstream-ece1323ed43aa8549d38ba123ca0ad88b95fa7f0.tar.gz
upstream-ece1323ed43aa8549d38ba123ca0ad88b95fa7f0.tar.bz2
upstream-ece1323ed43aa8549d38ba123ca0ad88b95fa7f0.zip
ar71xx: add kernel support for the My Net Wi-Fi Range Extender device
This patch adds a new device definition for a Western Digital device. The hardware seems to be based on Qualcomm Atheros DB120 design. Patchwork: http://patchwork.openwrt.org/patch/4281/ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com> [juhosg: refresh kernel patch] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38686
Diffstat (limited to 'target/linux/ar71xx/patches-3.10/632-MIPS-ath79-add-MyNet-Wifi-Range-Extender-support.patch')
-rw-r--r--target/linux/ar71xx/patches-3.10/632-MIPS-ath79-add-MyNet-Wifi-Range-Extender-support.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-3.10/632-MIPS-ath79-add-MyNet-Wifi-Range-Extender-support.patch b/target/linux/ar71xx/patches-3.10/632-MIPS-ath79-add-MyNet-Wifi-Range-Extender-support.patch
new file mode 100644
index 0000000000..dfbff45817
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.10/632-MIPS-ath79-add-MyNet-Wifi-Range-Extender-support.patch
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -56,6 +56,7 @@ enum ath79_mach_type {
+ ATH79_MACH_MR600V2, /* OpenMesh MR600v2 */
+ ATH79_MACH_MR600, /* OpenMesh MR600 */
+ ATH79_MACH_MYNET_N600, /* WD My Net N600 */
++ ATH79_MACH_MYNET_REXT, /* WD My Net Wi-Fi Range Extender */
+ ATH79_MACH_MZK_W04NU, /* Planex MZK-W04NU */
+ ATH79_MACH_MZK_W300NH, /* Planex MZK-W300NH */
+ ATH79_MACH_NBG460N, /* Zyxel NBG460N/550N/550NH */
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -67,6 +67,7 @@ obj-$(CONFIG_ATH79_MACH_JWAP003) += mach
+ obj-$(CONFIG_ATH79_MACH_HORNET_UB) += mach-hornet-ub.o
+ obj-$(CONFIG_ATH79_MACH_MR600) += mach-mr600.o
+ obj-$(CONFIG_ATH79_MACH_MYNET_N600) += mach-mynet-n600.o
++obj-$(CONFIG_ATH79_MACH_MYNET_REXT) += mach-mynet-rext.o
+ obj-$(CONFIG_ATH79_MACH_MZK_W04NU) += mach-mzk-w04nu.o
+ obj-$(CONFIG_ATH79_MACH_MZK_W300NH) += mach-mzk-w300nh.o
+ obj-$(CONFIG_ATH79_MACH_NBG460N) += mach-nbg460n.o
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -801,6 +801,16 @@ config ATH79_MACH_MYNET_N600
+ select ATH79_DEV_WMAC
+ select ATH79_NVRAM
+
++config ATH79_MACH_MYNET_REXT
++ bool "WD My Net Wi-Fi Range Extender board support"
++ select SOC_AR934X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_WMAC
++ select ATH79_NVRAM
++
+ config ATH79_MACH_ZCN_1523H
+ bool "Zcomax ZCN-1523H support"
+ select SOC_AR724X