aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.36/206-nxp-74hc153-gpio-chip-driver.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-10-08 12:10:18 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-10-08 12:10:18 +0000
commitff0ca066b820c970c900187d960f89c0506ea9d5 (patch)
tree059ad1fcf4d3fb24797ef02b4f4d92d5f74817a1 /target/linux/ar71xx/patches-2.6.36/206-nxp-74hc153-gpio-chip-driver.patch
parent03965bd6f312c14c35512aae8c0c1393ca662dbe (diff)
downloadupstream-ff0ca066b820c970c900187d960f89c0506ea9d5.tar.gz
upstream-ff0ca066b820c970c900187d960f89c0506ea9d5.tar.bz2
upstream-ff0ca066b820c970c900187d960f89c0506ea9d5.zip
linux/ar71xx: add preliminary 2.6.36 kernel support (refresh patches)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23317 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.36/206-nxp-74hc153-gpio-chip-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.36/206-nxp-74hc153-gpio-chip-driver.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.36/206-nxp-74hc153-gpio-chip-driver.patch b/target/linux/ar71xx/patches-2.6.36/206-nxp-74hc153-gpio-chip-driver.patch
new file mode 100644
index 0000000000..c2d097616f
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.36/206-nxp-74hc153-gpio-chip-driver.patch
@@ -0,0 +1,25 @@
+--- a/drivers/gpio/Kconfig
++++ b/drivers/gpio/Kconfig
+@@ -361,4 +361,12 @@ config GPIO_JANZ_TTL
+ This driver provides support for driving the pins in output
+ mode only. Input mode is not supported.
+
++comment "Other GPIO expanders"
++
++config GPIO_NXP_74HC153
++ tristate "NXP 74HC153 Dual 4-input multiplexer"
++ help
++ Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
++ provides a GPIO interface supporting inputs.
++
+ endif
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -17,6 +17,7 @@ obj-$(CONFIG_GPIO_MAX7301) += max7301.o
+ obj-$(CONFIG_GPIO_MAX732X) += max732x.o
+ obj-$(CONFIG_GPIO_MC33880) += mc33880.o
+ obj-$(CONFIG_GPIO_MCP23S08) += mcp23s08.o
++obj-$(CONFIG_GPIO_NXP_74HC153) += nxp_74hc153.o
+ obj-$(CONFIG_GPIO_PCA953X) += pca953x.o
+ obj-$(CONFIG_GPIO_PCF857X) += pcf857x.o
+ obj-$(CONFIG_GPIO_PL061) += pl061.o