aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.36/101-ksz8041_phy_driver.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-10-08 12:10:18 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-10-08 12:10:18 +0000
commitff0ca066b820c970c900187d960f89c0506ea9d5 (patch)
tree059ad1fcf4d3fb24797ef02b4f4d92d5f74817a1 /target/linux/ar71xx/patches-2.6.36/101-ksz8041_phy_driver.patch
parent03965bd6f312c14c35512aae8c0c1393ca662dbe (diff)
downloadupstream-ff0ca066b820c970c900187d960f89c0506ea9d5.tar.gz
upstream-ff0ca066b820c970c900187d960f89c0506ea9d5.tar.bz2
upstream-ff0ca066b820c970c900187d960f89c0506ea9d5.zip
linux/ar71xx: add preliminary 2.6.36 kernel support (refresh patches)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23317 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.36/101-ksz8041_phy_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.36/101-ksz8041_phy_driver.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.36/101-ksz8041_phy_driver.patch b/target/linux/ar71xx/patches-2.6.36/101-ksz8041_phy_driver.patch
new file mode 100644
index 0000000000..64418c9830
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.36/101-ksz8041_phy_driver.patch
@@ -0,0 +1,24 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -119,6 +119,11 @@ config RTL8306_PHY
+ tristate "Driver for Realtek RTL8306S switches"
+ select SWCONFIG
+
++config MICREL_PHY
++ tristate "Drivers for Micrel/Kendin PHYs"
++ ---help---
++ Currently has a driver for the KSZ8041
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -24,6 +24,7 @@ obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi
+ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
++obj-$(CONFIG_MICREL) += micrel.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+ obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o