aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.35/203-pb44_spi_controller.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-06-09 10:45:47 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-06-09 10:45:47 +0000
commitd45dc5e820b5589662236143a68928eaec01e83e (patch)
tree64a1434b436174e77545a6b7234612c5f0fdb3da /target/linux/ar71xx/patches-2.6.35/203-pb44_spi_controller.patch
parentbef7ceff095e5e648b45b4cf0c73fb7ad588b676 (diff)
downloadupstream-d45dc5e820b5589662236143a68928eaec01e83e.tar.gz
upstream-d45dc5e820b5589662236143a68928eaec01e83e.tar.bz2
upstream-d45dc5e820b5589662236143a68928eaec01e83e.zip
ar71xx: add kernel 2.6.35 preliminary support
SVN-Revision: 21734
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.35/203-pb44_spi_controller.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.35/203-pb44_spi_controller.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.35/203-pb44_spi_controller.patch b/target/linux/ar71xx/patches-2.6.35/203-pb44_spi_controller.patch
new file mode 100644
index 0000000000..9ac8d5b565
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.35/203-pb44_spi_controller.patch
@@ -0,0 +1,27 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -68,6 +68,14 @@ config SPI_AR71XX
+ help
+ This is the SPI contoller driver for Atheros AR71xx.
+
++config SPI_PB44
++ tristate "Atheros PB44 board specific SPI controller"
++ depends on SPI_MASTER && AR71XX_MACH_PB44
++ select SPI_BITBANG
++ help
++ This is a specific SPI controller driver for the Atheros PB44
++ reference board.
++
+ config SPI_ATMEL
+ tristate "Atmel SPI Controller"
+ depends on (ARCH_AT91 || AVR32)
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -27,6 +27,7 @@ obj-$(CONFIG_SPI_GPIO) += spi_gpio.o
+ obj-$(CONFIG_SPI_GPIO_OLD) += spi_gpio_old.o
+ obj-$(CONFIG_SPI_IMX) += spi_imx.o
+ obj-$(CONFIG_SPI_LM70_LLP) += spi_lm70llp.o
++obj-$(CONFIG_SPI_PB44) += pb44_spi.o
+ obj-$(CONFIG_SPI_PXA2XX) += pxa2xx_spi.o
+ obj-$(CONFIG_SPI_OMAP_UWIRE) += omap_uwire.o
+ obj-$(CONFIG_SPI_OMAP24XX) += omap2_mcspi.o