aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.34/201-ap83_spi_controller.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-03-11 12:25:50 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-03-11 12:25:50 +0000
commit94db5a4acc6c3489df3e7fb1a9f011babed9c379 (patch)
treee62a2fbcb087566a3b9d4f208b710076d8dfc2fa /target/linux/ar71xx/patches-2.6.34/201-ap83_spi_controller.patch
parentd138f99bb2325af7821b5ea592bf7e5602ef228e (diff)
downloadupstream-94db5a4acc6c3489df3e7fb1a9f011babed9c379.tar.gz
upstream-94db5a4acc6c3489df3e7fb1a9f011babed9c379.tar.bz2
upstream-94db5a4acc6c3489df3e7fb1a9f011babed9c379.zip
ar71xx: add 2.6.34 preliminary support (patches)
SVN-Revision: 20141
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.34/201-ap83_spi_controller.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.34/201-ap83_spi_controller.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.34/201-ap83_spi_controller.patch b/target/linux/ar71xx/patches-2.6.34/201-ap83_spi_controller.patch
new file mode 100644
index 0000000000..a8e889a7bd
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.34/201-ap83_spi_controller.patch
@@ -0,0 +1,27 @@
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -11,6 +11,7 @@ endif
+ obj-$(CONFIG_SPI_MASTER) += spi.o
+
+ # SPI master controller drivers (bus)
++obj-$(CONFIG_SPI_AP83) += ap83_spi.o
+ obj-$(CONFIG_SPI_AR71XX) += ar71xx_spi.o
+ obj-$(CONFIG_SPI_ATMEL) += atmel_spi.o
+ obj-$(CONFIG_SPI_BFIN) += spi_bfin5xx.o
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -53,6 +53,14 @@ if SPI_MASTER
+
+ comment "SPI Master Controller Drivers"
+
++config SPI_AP83
++ tristate "Atheros AP83 specific SPI Controller"
++ depends on SPI_MASTER && AR71XX_MACH_AP83
++ select SPI_BITBANG
++ help
++ This is a specific SPI controller driver for the Atheros AP83
++ reference board.
++
+ config SPI_AR71XX
+ tristate "Atheros AR71xx SPI Controller"
+ depends on SPI_MASTER && ATHEROS_AR71XX