aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.34/006-ar71xx_wdt_driver.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-03-11 12:25:50 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-03-11 12:25:50 +0000
commit94db5a4acc6c3489df3e7fb1a9f011babed9c379 (patch)
treee62a2fbcb087566a3b9d4f208b710076d8dfc2fa /target/linux/ar71xx/patches-2.6.34/006-ar71xx_wdt_driver.patch
parentd138f99bb2325af7821b5ea592bf7e5602ef228e (diff)
downloadupstream-94db5a4acc6c3489df3e7fb1a9f011babed9c379.tar.gz
upstream-94db5a4acc6c3489df3e7fb1a9f011babed9c379.tar.bz2
upstream-94db5a4acc6c3489df3e7fb1a9f011babed9c379.zip
ar71xx: add 2.6.34 preliminary support (patches)
SVN-Revision: 20141
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.34/006-ar71xx_wdt_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.34/006-ar71xx_wdt_driver.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.34/006-ar71xx_wdt_driver.patch b/target/linux/ar71xx/patches-2.6.34/006-ar71xx_wdt_driver.patch
new file mode 100644
index 0000000000..d71a11b86a
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.34/006-ar71xx_wdt_driver.patch
@@ -0,0 +1,26 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -840,6 +840,13 @@ config TXX9_WDT
+ help
+ Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
+
++config AR71XX_WDT
++ tristate "Atheros AR71xx Watchdog Timer"
++ depends on ATHEROS_AR71XX
++ help
++ Hardware driver for the built-in watchdog timer on the Atheros
++ AR71xx SoCs.
++
+ # PARISC Architecture
+
+ # POWERPC Architecture
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -112,6 +112,7 @@ obj-$(CONFIG_PNX833X_WDT) += pnx833x_wdt
+ obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
+ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
++obj-$(CONFIG_AR71XX_WDT) += ar71xx_wdt.o
+
+ # PARISC Architecture
+