aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.32
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-01-20 09:30:36 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-01-20 09:30:36 +0000
commit5e5451a54d2c3bcca2e876be4a2d34b8da59b9b8 (patch)
treea341b5fb8a8a2e8f7a0b2deb581ccdca07b4fe45 /target/linux/ar71xx/patches-2.6.32
parent0d48b043b1540a6f12a5319133ac98f5c43a42fb (diff)
downloadupstream-5e5451a54d2c3bcca2e876be4a2d34b8da59b9b8.tar.gz
upstream-5e5451a54d2c3bcca2e876be4a2d34b8da59b9b8.tar.bz2
upstream-5e5451a54d2c3bcca2e876be4a2d34b8da59b9b8.zip
rtl8366_smi: add Kconfig option for the debugfs stuff
SVN-Revision: 19243
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.32')
-rw-r--r--target/linux/ar71xx/patches-2.6.32/204-rtl8366-smi-driver.patch8
1 files changed, 7 insertions, 1 deletions
diff --git a/target/linux/ar71xx/patches-2.6.32/204-rtl8366-smi-driver.patch b/target/linux/ar71xx/patches-2.6.32/204-rtl8366-smi-driver.patch
index 78ec2e44c0..383513cda7 100644
--- a/target/linux/ar71xx/patches-2.6.32/204-rtl8366-smi-driver.patch
+++ b/target/linux/ar71xx/patches-2.6.32/204-rtl8366-smi-driver.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -146,4 +146,8 @@ config MDIO_GPIO
+@@ -146,4 +146,14 @@ config MDIO_GPIO
To compile this driver as a module, choose M here: the module
will be called mdio-gpio.
@@ -8,6 +8,12 @@
+ tristate "Support for RTL8366 switch via SMI interface"
+ depends on GENERIC_GPIO
+
++config RTL8366_SMI_DEBUG_FS
++ bool "RTL8366S driver DEBUG_FS support"
++ depends on RTL8366_SMI
++ depends on DEBUG_FS
++ default n
++
endif # PHYLIB
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile