aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.32
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-03-11 18:48:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-03-11 18:48:50 +0000
commit2d305bdc2338b3295d6338a0215ce4cf7bb027f8 (patch)
tree52edacb46a5af6296761d2dd3de42515f2841b28 /target/linux/ar71xx/patches-2.6.32
parentc3ddcedf4a2e1c4597d7c2d1f06a82b36df62695 (diff)
downloadupstream-2d305bdc2338b3295d6338a0215ce4cf7bb027f8.tar.gz
upstream-2d305bdc2338b3295d6338a0215ce4cf7bb027f8.tar.bz2
upstream-2d305bdc2338b3295d6338a0215ce4cf7bb027f8.zip
the mips -ffreestanding patch has been unnecessary for a long time now, remove it
SVN-Revision: 20149
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.32')
-rw-r--r--target/linux/ar71xx/patches-2.6.32/001-ar71xx_core.patch10
-rw-r--r--target/linux/ar71xx/patches-2.6.32/300-mips_fw_myloader.patch2
2 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/ar71xx/patches-2.6.32/001-ar71xx_core.patch b/target/linux/ar71xx/patches-2.6.32/001-ar71xx_core.patch
index c33e902e9e..e1a1e3efe3 100644
--- a/target/linux/ar71xx/patches-2.6.32/001-ar71xx_core.patch
+++ b/target/linux/ar71xx/patches-2.6.32/001-ar71xx_core.patch
@@ -1,7 +1,7 @@
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
-@@ -624,6 +624,13 @@ else
- load-$(CONFIG_CPU_CAVIUM_OCTEON) += 0xffffffff81100000
+@@ -156,6 +156,13 @@ ifeq (,$(findstring march=octeon, $(cfla
+ cflags-$(CONFIG_CPU_CAVIUM_OCTEON) += -Wa,-march=octeon
endif
+#
@@ -11,9 +11,9 @@
+cflags-$(CONFIG_ATHEROS_AR71XX) += -I$(srctree)/arch/mips/include/asm/mach-ar71xx
+load-$(CONFIG_ATHEROS_AR71XX) += 0xffffffff80060000
+
- # temporary until string.h is fixed
- cflags-y += -ffreestanding
-
+ cflags-$(CONFIG_CPU_R4000_WORKAROUNDS) += $(call cc-option,-mfix-r4000,)
+ cflags-$(CONFIG_CPU_R4400_WORKAROUNDS) += $(call cc-option,-mfix-r4400,)
+ cflags-$(CONFIG_CPU_DADDI_WORKAROUNDS) += $(call cc-option,-mno-daddi,)
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
@@ -43,6 +43,23 @@ config AR7
diff --git a/target/linux/ar71xx/patches-2.6.32/300-mips_fw_myloader.patch b/target/linux/ar71xx/patches-2.6.32/300-mips_fw_myloader.patch
index 8a834607d2..7eb150e40c 100644
--- a/target/linux/ar71xx/patches-2.6.32/300-mips_fw_myloader.patch
+++ b/target/linux/ar71xx/patches-2.6.32/300-mips_fw_myloader.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
-@@ -169,6 +169,7 @@ endif
+@@ -178,6 +178,7 @@ endif
#
libs-$(CONFIG_ARC) += arch/mips/fw/arc/
libs-$(CONFIG_CFE) += arch/mips/fw/cfe/