aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2016-10-08 01:17:04 +0200
committerJohn Crispin <john@phrozen.org>2016-11-21 10:05:40 +0100
commiteb9ba2b91e0f0c2d0b072b3fea3ea2a8b50af5fc (patch)
tree9b881025fb7f4d892f7959a1a080ca16f7565c84 /target/linux/ar71xx/image
parent9ee8257cc7ed45cde07558a3b9e5310d16ad078d (diff)
downloadupstream-eb9ba2b91e0f0c2d0b072b3fea3ea2a8b50af5fc.tar.gz
upstream-eb9ba2b91e0f0c2d0b072b3fea3ea2a8b50af5fc.tar.bz2
upstream-eb9ba2b91e0f0c2d0b072b3fea3ea2a8b50af5fc.zip
ar71xx: add support for YunCore CPE870
YunCore CPE870 is an outdoor CPE/AP based on Atheros AR9341. Short specification: - 535/400/200 MHz (CPU/DDR/AHB) - 2x 10/100 Mbps Ethernet, passive PoE support - 64/128 MB of RAM (DDR2) - 8 MB of FLASH - 2T2R 2.4 GHz with external PA (SKY65174-21), up to 30 dBm - internal 14 dBi panel antenna - 8x LED, 1x button - UART (JP1) header on PCB Flash instruction (do it under U-Boot, using UART): 1. tftp 0x80060000 lede-ar71xx-generic-cpe870-squashfs-sysupgrade.bin 2. erase 0x9f020000 +$filesize 3. cp.b $fileaddr 0x9f020000 $filesize 4. setenv bootcmd "bootm 0x9f020000" 5. saveenv && reset Vendor firmware access (login/password): Admin/5up Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/generic.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 0c32cddfdd..0b8a216a25 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -80,6 +80,16 @@ define Device/cf-e530n
endef
TARGET_DEVICES += cf-e530n
+define Device/cpe870
+ DEVICE_TITLE := YunCore CPE870
+ DEVICE_PACKAGES := rssileds
+ BOARDNAME = CPE870
+ IMAGE_SIZE = 7936k
+ CONSOLE = ttyS0,115200
+ MTDPARTS = spi0.0:64k(u-boot)ro,64k(u-boot-env),7936k(firmware),64k(config)ro,64k(art)ro
+endef
+TARGET_DEVICES += cpe870
+
define Device/domywifi-dw33d
DEVICE_TITLE := DomyWifi DW33D
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage kmod-ledtrig-usbdev kmod-ath10k