aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-05-23 21:05:24 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-05-23 21:05:24 +0000
commitd9f7205aa479e16db9cd320129046a7c0c051165 (patch)
treed08f9ac52ee79f47dccbc388e33a8d1959730d73 /target/linux/ar71xx/image
parentdb37661614728e71e18b676dfaf2dc03504f5345 (diff)
downloadupstream-d9f7205aa479e16db9cd320129046a7c0c051165.tar.gz
upstream-d9f7205aa479e16db9cd320129046a7c0c051165.tar.bz2
upstream-d9f7205aa479e16db9cd320129046a7c0c051165.zip
ar71xx: add support for TP-Link TL-MR3040
Support for TP-Link TL-MR3040. Power LED not working - always on red, after start should be green. Signed-off-by: Cezary Jackiewicz <cezary.jackiewicz@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31845 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index f99c01ab15..2f6a161cfd 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -877,6 +877,11 @@ define Image/Build/Profile/TLMR3020
$(call Image/Build/Template/$(fs_64k)/$(1),TPLINK-LZMA,tl-mr3020-v1,$(tlmr3020_cmdline),0x30200001,1,4Mlzma)
endef
+tlmr3040_cmdline=board=TL-MR11U console=ttyATH0,115200
+define Image/Build/Profile/TLMR3040
+ $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-mr3040-v1,$(tlmr3040_cmdline),0x30400001,1,4Mlzma)
+endef
+
tlmr3220_cmdline=board=TL-MR3220 console=ttyS0,115200
define Image/Build/Profile/TLMR3220
$(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK,tl-mr3220-v1,$(tlmr3220_cmdline),0x32200001,1,4M)
@@ -1081,6 +1086,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/TEW673GRU,$(1))
$(call Image/Build/Profile/TLMR11U,$(1))
$(call Image/Build/Profile/TLMR3020,$(1))
+ $(call Image/Build/Profile/TLMR3040,$(1))
$(call Image/Build/Profile/TLMR3220,$(1))
$(call Image/Build/Profile/TLMR3420,$(1))
$(call Image/Build/Profile/TLWA701,$(1))