aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
author张鹏 <sd20@qxwlan.com>2018-07-17 18:08:10 +0800
committerJohn Crispin <john@phrozen.org>2018-07-30 10:43:36 +0200
commitb74f63f81d6121b5eace3f0c0c87399f7e0fde92 (patch)
tree2d45b29da178ec23a45436fabfa79c6d80e2af9d /target/linux/ar71xx/image
parent0aaa65075508035bdf6c8fc8fa9a79b94dc5eadc (diff)
downloadupstream-b74f63f81d6121b5eace3f0c0c87399f7e0fde92.tar.gz
upstream-b74f63f81d6121b5eace3f0c0c87399f7e0fde92.tar.bz2
upstream-b74f63f81d6121b5eace3f0c0c87399f7e0fde92.zip
ar71xx:add support for E558 v2
Qxwlan E558 v2 is based on Qualcomm QCA9558 + AR8327. Specification: - 720/600/200 MHz (CPU/DDR/AHB) - 128 MB of RAM (DDR2) - 8/16 MB of FLASH (SPI NOR) - 2T2R 2.4 GHz (QCA9558) - 3x 10/100/1000 Mbps Ethernet (one port with PoE support) - 4x miniPCIe slot (USB 2.0 bus only) - 1x microSIM slot - 5x LED (4 driven by GPIO) - 1x button (reset) - 1x 3-pos switch - 1x DC jack for main power input (9-48 V) - UART (JP5) and LEDs (J8) headers on PCB Flash instruction (using U-Boot CLI and tftp server): - Configure PC with static IP 192.168.1.10 and tftp server. - Rename "sysupgrade" filename to "firmware.bin" and place it in tftp server directory. - Connect PC with one of RJ45 ports, power up the board and press "enter" key to access U-Boot CLI. - Use the following command to update the device to OpenWrt: "run lfw". Flash instruction (using U-Boot web-based recovery): - Configure PC with static IP 192.168.1.xxx(2-254)/24. - Connect PC with one of RJ45 ports, press the reset button, power up the board and keep button pressed for around 6-7 seconds, until LEDs start flashing. - Open your browser and enter 192.168.1.1, select "sysupgrade" image and click the upgrade button. Signed-off-by: 张鹏 <sd20@qxwlan.com>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/generic.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 3da57e4698..dedc19d52c 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -326,6 +326,25 @@ define Device/e1700ac-v2-8M
endef
TARGET_DEVICES += e1700ac-v2-8M
+define Device/e558-v2-16M
+ DEVICE_TITLE := Qxwlan E558 v2 (16MB flash)
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 -swconfig
+ BOARDNAME := E558-V2
+ SUPPORTED_DEVICES := e558-v2
+ IMAGE_SIZE := 15936k
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),64k(pri-data)ro,64k(art),-(firmware)
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) |\
+ append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += e558-v2-16M
+
+define Device/e558-v2-8M
+ $(Device/e558-v2-16M)
+ DEVICE_TITLE := Qxwlan E558 v2 (8MB flash)
+ IMAGE_SIZE := 7744k
+endef
+TARGET_DEVICES += e558-v2-8M
+
define Device/e600g-v2-16M
DEVICE_TITLE := Qxwlan E600G v2 (16MB flash)
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 -swconfig