aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-12-10 15:17:03 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-12-10 15:17:03 +0000
commitb0c01de62dcad7623267120c77678b65953143f6 (patch)
treebe00375a7d8dc70504b0877be7d7f0ad78506fa4 /target/linux/ar71xx/image
parent89cf40ace9fb8a2214e57f95186230d3c7f090a5 (diff)
downloadupstream-b0c01de62dcad7623267120c77678b65953143f6.tar.gz
upstream-b0c01de62dcad7623267120c77678b65953143f6.tar.bz2
upstream-b0c01de62dcad7623267120c77678b65953143f6.zip
ar71xx: add nbg460n image generation
This adds image generation for NBG460N/550N/550NH boards. Signed-off-by: Michael Kurz <michi.kurz@googlemail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24419 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 313a6429e6..4c96a88bcf 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -373,6 +373,29 @@ define Image/Build/WNDR3700
-o $(call imgname,$(1),$(2))-factory.img
endef
+define Image/Build/ZyXEL
+ $(call PatchKernelLzma,$(2),$(3))
+ if [ `stat -c%s "$(KDIR)/vmlinux-$(2).bin.lzma"` -gt 917504 ]; then \
+ echo "Warning: $(KDIR)/vmlinux-$(2).bin.lzma is too big"; \
+ else if [ `stat -c%s $(KDIR)/root.$(1)` -gt 2752512 ]; then \
+ echo "Warning: $(KDIR)/root.$(1) is too big"; \
+ else \
+ mkimage -A mips -O linux -T kernel -a 0x80060000 -C lzma -e \
+ 0x80060000 \
+ -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/vmlinux-$(2).uImage; \
+ ( \
+ dd if=$(KDIR)/vmlinux-$(2).uImage bs=896k conv=sync; \
+ dd if=$(KDIR)/root.$(1); \
+ ) > $(call imgname,$(1),$(2))-sysupgrade.bin; \
+ $(STAGING_DIR_HOST)/bin/mkzynfw \
+ -B $(4) \
+ -b $(BIN_DIR)/$(IMG_PREFIX)-$(2)-u-boot.bin \
+ -r $(call imgname,$(1),$(2))-sysupgrade.bin:0x10000 \
+ -o $(call imgname,$(1),$(2))-factory.bin; \
+ fi; fi
+endef
+
define Image/Build/WNDR3700/initramfs
$(call PatchKernelLzma,$(2),$(3) $(wndr3700_mtdlayout))
$(call MkImageLzma,$(KDIR)/vmlinux-$(2).bin.lzma,$(KDIR)/vmlinux-$(2).uImage)
@@ -541,6 +564,10 @@ define Image/Build/Profile/MZKW300NH
$(call Image/Build/Template/$(fs_64k)/$(1),Planex,mzk-w300nh,board=MZK-W300NH)
endef
+define Image/Build/Profile/NBG_460N_550N_550NH
+ $(call Image/Build/Template/$(fs_64k)/$(1),ZyXEL,nbg460n_550n_550nh,board=NBG460N,NBG-460N)
+endef
+
define Image/Build/Profile/TLMR3420V1
$(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-mr3420-v1,board=TL-MR3420,TL-MR3420v1)
endef
@@ -629,6 +656,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/JWAP003,$(1))
$(call Image/Build/Profile/MZKW04NU,$(1))
$(call Image/Build/Profile/MZKW300NH,$(1))
+ $(call Image/Build/Profile/NBG_460N_550N_550NH,$(1))
$(call Image/Build/Profile/PB42,$(1))
$(call Image/Build/Profile/PB44,$(1))
$(call Image/Build/Profile/PB92,$(1))