aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-07-11 17:15:30 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-07-11 17:15:30 +0000
commitabd419a7df4261f561f7991d761741e8fc072839 (patch)
treea2fc2c7953b38ad6c92020615c9562744835df68 /target/linux/ar71xx/image
parent2dc230d260b378fda69cb5d7f8b0cfa9e81e9e1d (diff)
downloadupstream-abd419a7df4261f561f7991d761741e8fc072839.tar.gz
upstream-abd419a7df4261f561f7991d761741e8fc072839.tar.bz2
upstream-abd419a7df4261f561f7991d761741e8fc072839.zip
increase size of the kernel partition on the TEW-632BR board
SVN-Revision: 16784
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 17d20dfa50..b4e433e9c4 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -61,9 +61,9 @@ define Image/Build/AP81
cp $(KDIR)/vmlinux $(KDIR)/vmlinux-$(2)
$(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux-$(2) '$(strip $(3))'
$(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux-$(2) $(KDIR)/vmlinux-$(2).bin.lzma
- if [ `stat -c%s "$(KDIR)/vmlinux-$(2).bin.lzma"` -gt 786432 ]; then \
+ if [ `stat -c%s "$(KDIR)/vmlinux-$(2).bin.lzma"` -gt 851968 ]; then \
echo "Warning: $(KDIR)/vmlinux-$(2).bin.lzma is too big"; \
- else if [ `stat -c%s $(KDIR)/root.$(1)` -gt 3080192 ]; then \
+ else if [ `stat -c%s $(KDIR)/root.$(1)` -gt 3014656 ]; then \
echo "Warning: $(KDIR)/root.$(1) is too big"; \
else \
mkimage -A mips -O linux -T kernel -a 0x80060000 -C lzma -e \
@@ -71,8 +71,8 @@ define Image/Build/AP81
-n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
-d $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/vmlinux-$(2).uImage; \
( \
- dd if=$(KDIR)/vmlinux-$(2).uImage bs=768k conv=sync; \
- dd if=$(KDIR)/root.$(1) bs=3008k conv=sync; \
+ dd if=$(KDIR)/vmlinux-$(2).uImage bs=832k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=2944k conv=sync; \
echo -n $(4); \
) > $(call imgname,$(1),$(2)).uni; \
fi; fi