aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-11-30 18:30:59 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-11-30 18:30:59 +0000
commita03d5162b4444fa18efdffcb74734697e81f1a56 (patch)
treeca46812eae7eb89d82e01d2793bc0da262d67466 /target/linux/ar71xx/image
parent84379f8240f6bdbebacf6d96387560b7f59207d1 (diff)
downloadupstream-a03d5162b4444fa18efdffcb74734697e81f1a56.tar.gz
upstream-a03d5162b4444fa18efdffcb74734697e81f1a56.tar.bz2
upstream-a03d5162b4444fa18efdffcb74734697e81f1a56.zip
ar71xx: image: fix CyberTAN sysupgrade images
In the current sysupgrade images, the CRC32 value of the TRX header covers the whole rootfs data. Due to this, the CRC value should be changed during sysupgrade otherwise the bootloader refuses to load the image on the next boot. Change the image generation to create sysupgrade images where the CRC32 value covers the kernel data only. This allows to skip the 'fixtrx' step during sysupgrade on the target. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38964 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 8511bba350..dee44077bf 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -668,11 +668,15 @@ Image/Build/CyberTAN/loader=$(call Image/BuildLoader,$(1),gz,$(2),0x80060000)
Image/Build/CyberTAN/buildkernel=$(call MkuImage,gzip,,$(KDIR)/loader-$(2).gz,$(KDIR_TMP)/vmlinux-$(2).uImage)
define Image/Build/CyberTAN
- $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/image.tmp -f $(KDIR_TMP)/vmlinux-$(2).uImage \
+ echo -n '' > $(KDIR_TMP)/empty.bin
+ $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/image.tmp \
+ -f $(KDIR_TMP)/vmlinux-$(2).uImage -F $(KDIR_TMP)/empty.bin \
-x 32 -a 0x10000 -x -32 -f $(KDIR)/root.$(1)
-$(STAGING_DIR_HOST)/bin/addpattern -B $(2) -v v$(4) \
-i $(KDIR)/image.tmp \
-o $(call sysupname,$(1),$(2))
+ $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/image.tmp -f $(KDIR_TMP)/vmlinux-$(2).uImage \
+ -x 32 -a 0x10000 -x -32 -f $(KDIR)/root.$(1)
-$(STAGING_DIR_HOST)/bin/addpattern -B $(2) -v v$(4) -g \
-i $(KDIR)/image.tmp \
-o $(call factoryname,$(1),$(2))