aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-07-03 15:24:01 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-07-03 15:24:01 +0000
commit86013d40d5d82dd72a9317aaf88096461ada60ad (patch)
treebfc0e770b5ab372b8f328761cddd46c4b3f0fc7c /target/linux/ar71xx/image
parent5d19a38d8008411f06b8beb265d94890690f562b (diff)
downloadupstream-86013d40d5d82dd72a9317aaf88096461ada60ad.tar.gz
upstream-86013d40d5d82dd72a9317aaf88096461ada60ad.tar.bz2
upstream-86013d40d5d82dd72a9317aaf88096461ada60ad.zip
ar71xx: remove the built-in MTD map of the ALL0258N
Pass the mtd_layout via the kernel command line instead. Also increase the kernel partition size to 1024k, so current kernel can fit in. Signed-off-by: Daniel Golle <dgolle@allnet.de> SVN-Revision: 32585
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 06e39561d7..13fb0ae02a 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -655,6 +655,12 @@ define Image/Build/Profile/ALFAAP96
$(call Image/Build/Template/$(fs_128k)/$(1),AthLzma,alfa-ap96,$(alfa_ap96_cmdline),$(alfa_ap96_mtdlayout),2097152,13631488,RKuImage)
endef
+all0258n_cmdline=board=ALL0258N console=ttyS0,115200
+all0258n_mtdlayout=mtdparts=spi0.0:256k(u-boot),64k(u-boot-env),1024k(kernel),5248k(rootfs),1536k(failsafe),64k(art),6272k@0x50000(firmware)
+define Image/Build/Profile/ALL0258N
+ $(call Image/Build/Template/$(fs_64k)/$(1),AthLzma,all0258n,$(all0258n_cmdline),$(all0258n_mtdlayout),1048576,5373952,KRuImage)
+endef
+
ap113_mtd_layout=64k(u-boot),3008k(rootfs),896k(uImage),64k(NVRAM),64k(ART),3904k@0x10000(firmware)
ap113_cmdline=board=AP113 console=ttyS0,115200
define Image/Build/Profile/AP113
@@ -1057,11 +1063,6 @@ define Image/Build/Profile/ZCN1523H516
$(call Image/Build/Template/$(fs_64k)/$(1),Zcomax,zcn-1523h-5-16,$(zcn1523h516_cmdline))
endef
-all0258n_cmdline=board=ALL0258N console=ttyS0,115200
-define Image/Build/Profile/ALL0258N
- $(call Image/Build/Template/$(fs_64k)/$(1),AthLzma,all0258n,$(all0258n_cmdline),,917504,5505024,KRuImage)
-endef
-
define Image/Build/Profile/Default
$(call Image/Build/Profile/ALFAAP96,$(1))
$(call Image/Build/Profile/ALFANX,$(1))