aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-03-27 19:38:11 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-03-27 19:38:11 +0000
commit4251611f6f082bc2d0cec2bd0cb00d622052441f (patch)
treebf6fa22b19087bd18b09bd2b71b3e2b6c97682f5 /target/linux/ar71xx/image
parent2f5d4465f9fe220421de35df760fe1df95d84d7b (diff)
downloadupstream-4251611f6f082bc2d0cec2bd0cb00d622052441f.tar.gz
upstream-4251611f6f082bc2d0cec2bd0cb00d622052441f.tar.bz2
upstream-4251611f6f082bc2d0cec2bd0cb00d622052441f.zip
ar71xx: image: add MkuImage{Gzip,Lzma}/initramfs helpers
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31115 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index acfa831883..da4d1fde5c 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -68,11 +68,21 @@ define MkuImageLzma
$(call MkuImage,lzma,,$(KDIR_TMP)/vmlinux-$(1).bin.lzma,$(KDIR_TMP)/vmlinux-$(1).uImage)
endef
+define MkuImageLzma/initramfs
+ $(call PatchKernelLzma,$(1),$(2))
+ $(call MkuImage,lzma,,$(KDIR_TMP)/vmlinux-$(1).bin.lzma,$(call imgname,initramfs,$(1))-uImage.bin)
+endef
+
define MkuImageGzip
$(call PatchKernelGzip,$(1),$(2))
$(call MkuImage,gzip,,$(KDIR_TMP)/vmlinux-$(1).bin.gz,$(KDIR_TMP)/vmlinux-$(1).uImage)
endef
+define MkuImageGzip/initramfs
+ $(call PatchKernelGzip,$(1),$(2))
+ $(call MkuImage,gzip,,$(KDIR_TMP)/vmlinux-$(1).bin.gz,$(call imgname,initramfs,$(1))-uImage.bin)
+endef
+
define MkuImageOKLI
$(call MkuImage,lzma,-M 0x4f4b4c49,$(KDIR)/vmlinux.bin.lzma,$(KDIR_TMP)/vmlinux-$(1).okli)
endef
@@ -232,8 +242,7 @@ define Image/Build/AthGzip
endef
define Image/Build/AthGzip/initramfs
- $(call MkuImageGzip,$(2),$(3) $(4))
- $(CP) $(KDIR_TMP)/vmlinux-$(2).uImage $(call imgname,$(1),$(2))-uImage.bin
+ $(call MkuImageGzip/initramfs,$(2),$(3) $(4))
endef
define Image/Build/AthLzma
@@ -242,8 +251,7 @@ define Image/Build/AthLzma
endef
define Image/Build/AthLzma/initramfs
- $(call MkuImageLzma,$(2),$(3) $(4))
- $(CP) $(KDIR_TMP)/vmlinux-$(2).uImage $(call imgname,$(1),$(2))-uImage.bin
+ $(call MkuImageLzma/initramfs,$(2),$(3) $(4))
endef
define Image/Build/PB4X