aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-03-11 14:03:28 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-03-11 14:03:28 +0000
commit3cd6cb21cd3648cbb6527662a1f5f2509b0eb127 (patch)
treebd055302b6e3867cf41aa1087cba3bf6e605f14f /target/linux/ar71xx/image
parentc1a889d1a3cfc4c4086c6a7c99646f22cf1cd48d (diff)
downloadupstream-3cd6cb21cd3648cbb6527662a1f5f2509b0eb127.tar.gz
upstream-3cd6cb21cd3648cbb6527662a1f5f2509b0eb127.tar.bz2
upstream-3cd6cb21cd3648cbb6527662a1f5f2509b0eb127.zip
ar71xx: stop image building if a loader is missing
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30877 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index f7df1026a1..8fcaa08d1a 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -299,6 +299,7 @@ define Image/Build/Planex/loader
endef
define Image/Build/Planex
+ [ -e "$(KDIR)/loader-$(2).gz" ]
$(call MkuImage,gzip,,$(KDIR)/loader-$(2).gz,$(KDIR_TMP)/vmlinux-$(2).uImage)
$(call MkuImageOKLI,$(2))
( \
@@ -338,6 +339,7 @@ define Image/Build/TPLINKOLD/loader
endef
define Image/Build/TPLINKOLD
+ [ -e "$(KDIR)/loader-$(2).gz" ]
$(call MkuImageOKLI,$(2))
( \
dd if=$(KDIR)/loader-$(2).gz bs=7680 count=1 conv=sync; \
@@ -368,6 +370,7 @@ define Image/Build/TPLINK/loader
endef
define Image/Build/TPLINK
+ [ -e "$(KDIR)/loader-$(2).gz" ]
$(call MkuImageOKLI,$(2))
( \
dd if=$(KDIR)/loader-$(2).gz bs=7680 count=1 conv=sync; \