aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-03-27 19:38:05 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-03-27 19:38:05 +0000
commit35c72f864eb82ea3a1d66723c277b558c4ac2cf3 (patch)
tree41658d29fa00c9fae5f87a67dc86dab1ceddf8aa /target/linux/ar71xx/image
parent1f4578115c1bfb9a7e315fc6de73301c26802db3 (diff)
downloadupstream-35c72f864eb82ea3a1d66723c277b558c4ac2cf3.tar.gz
upstream-35c72f864eb82ea3a1d66723c277b558c4ac2cf3.tar.bz2
upstream-35c72f864eb82ea3a1d66723c277b558c4ac2cf3.zip
ar71xx: remove the built-in MTD map of the PB92 board
Pass the mtd_layout via the kernel command line instead git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31111 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index d6fc008954..2203bec2e5 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -679,8 +679,9 @@ define Image/Build/Profile/PB44
endef
pb92_cmdline=board=PB92 console=ttyS0,115200
+pb92_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,2752k(rootfs),896k(kernel),64k(nvram),64k(art)ro,3648k@0x50000(firmware)
define Image/Build/Profile/PB92
- $(call Image/Build/Template/$(fs_64k)/$(1),AthLzma,pb92,$(pb92_cmdline),,917504,2818048,KRuImage)
+ $(call Image/Build/Template/$(fs_64k)/$(1),AthLzma,pb92,$(pb92_cmdline),$(pb92_mtdlayout),917504,2818048,KRuImage)
endef
wp543_cmdline=console=ttyS0,115200