aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-02-13 17:11:58 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-02-13 17:11:58 +0000
commit1c8bb38b682989c69feab90355c84266c8106f56 (patch)
tree24690f2a2befd4e6b623e34bfae11d5cf6c70c8c /target/linux/ar71xx/image
parent87adb998bcd7c1639e39369af03328575fe77310 (diff)
downloadupstream-1c8bb38b682989c69feab90355c84266c8106f56.tar.gz
upstream-1c8bb38b682989c69feab90355c84266c8106f56.tar.bz2
upstream-1c8bb38b682989c69feab90355c84266c8106f56.zip
ar71xx: add profile and build image for the TP-Link TL-WR842N/ND v1 boards
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30508 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index f923efc370..86e279f0a7 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -892,6 +892,11 @@ define Image/Build/Profile/TLWR841
$(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK,tl-wr841nd-v7,$(tlwr841v7_cmdline),0x08410007,1,4M)
endef
+tlwr842_cmdline=board=TL-MR3420 console=ttyS0,115200
+define Image/Build/Profile/TLWR842
+ $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK,tl-wr842n-v1,$(tlwr842_cmdline),0x08420001,1,8M)
+endef
+
tlwr941v2_cmdline=board=TL-WR941ND console=ttyS0,115200
tlwr941v4_cmdline=board=TL-WR741ND console=ttyS0,115200
define Image/Build/Profile/TLWR941
@@ -1034,6 +1039,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/TLWR741,$(1))
$(call Image/Build/Profile/TLWR743,$(1))
$(call Image/Build/Profile/TLWR841,$(1))
+ $(call Image/Build/Profile/TLWR842,$(1))
$(call Image/Build/Profile/TLWR941,$(1))
$(call Image/Build/Profile/TLWR1043,$(1))
$(call Image/Build/Profile/TLWR2543,$(1))