aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2016-10-06 02:19:17 +0200
committerJohn Crispin <john@phrozen.org>2016-11-21 10:05:40 +0100
commit01dda0659eb7d029672af3bd3b590d98e2ee0a5d (patch)
tree9b8fe4c36ee3a15a34bc97606489d3a98be1c14e /target/linux/ar71xx/image
parent16afa08d19b4f7bf256a89749e76ff8421ece013 (diff)
downloadupstream-01dda0659eb7d029672af3bd3b590d98e2ee0a5d.tar.gz
upstream-01dda0659eb7d029672af3bd3b590d98e2ee0a5d.tar.bz2
upstream-01dda0659eb7d029672af3bd3b590d98e2ee0a5d.zip
ar71xx: add support for YunCore AP90Q
YunCore AP90Q is an outdoor CPE/AP based on Qualcomm/Atheros QCA9531 v2. Short specification: - 650/600/216 MHz (CPU/DDR/AHB) - 2x 10/100 Mbps Ethernet, passive PoE support - 64/128 MB of RAM (DDR2) - 16 MB of FLASH - 2T2R 2.4 GHz with external PA, up to 29 dBm - 2x internal 5 dBi omni antennas - 4x LED, 1x button - UART (JP1) header on PCB Flash instruction under U-Boot, using UART: 1. tftp 0x80060000 lede-ar71xx-generic-ap90q-squashfs-sysupgrade 2. erase 0x9f050000 +$filesize 3. cp.b $fileaddr 0x9f050000 $filesize 4. setenv bootcmd "bootm 0x9f050000" 5. saveenv && reset Flash instruction under vendor fimrware, using telnet/SSH: 1. Connect PC with 192.168.1.x address to WAN port 2. Power up device, enter failsafe mode with button (no LED indicator!) 3. Change root password and reboot (mount_root, passwd ..., reboot -f) 4. Upload lede-ar71xx-generic-ap90q-squashfs-sysupgrade.bin to /tmp using SCP 5. Connect PC with 192.168.188.x address to LAN port, SSH to 192.168.188.253 6. Invoke: - cd /tmp - fw_setenv bootcmd "bootm 0x9f050000" - mtd erase firmware - mtd -r write lede-ar71xx-generic-ap90q-squashfs-sysupgrade.bin firmware Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/generic.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 7381eecb9f..0c32cddfdd 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -1,3 +1,12 @@
+define Device/ap90q
+ DEVICE_TITLE := YunCore AP90Q
+ BOARDNAME = AP90Q
+ IMAGE_SIZE = 16000k
+ CONSOLE = ttyS0,115200
+ MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env),16000k(firmware),64k(art)ro
+endef
+TARGET_DEVICES += ap90q
+
define Device/bsb
DEVICE_TITLE := Smart Electronics Black Swift board
DEVICE_PACKAGES := kmod-usb-core kmod-usb2