aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorChristian Mehlis <christian@m3hlis.de>2017-02-26 12:25:57 +0100
committerJohn Crispin <john@phrozen.org>2017-03-30 09:57:22 +0200
commitdc4eae7a8cf676911b0048b1e73c6f9adeea2f06 (patch)
treeaabdb124ca654ccb242f3588231bfbdf1ca6c402 /target/linux/ar71xx/image
parent967b6be118e3217e8d6a28df9c615d3255e7b1ae (diff)
downloadupstream-dc4eae7a8cf676911b0048b1e73c6f9adeea2f06.tar.gz
upstream-dc4eae7a8cf676911b0048b1e73c6f9adeea2f06.tar.bz2
upstream-dc4eae7a8cf676911b0048b1e73c6f9adeea2f06.zip
ar71xx: Compex WPJ563 support
Specification: - SoC: Qualcomm Atheros QCA9563 (775 MHz, MIPS 74Kc) - RAM: 128 MiB - Storage: 16MB NOR flash - Wireless: Built into QCA9563 (Dragonfly), PHY modes b/g/n, 3x3 MIMO - Ethernet: 2x1G Tested and working: - ethernet / switch / lan / wan - 2.4GHz SoC wifi - PCIe - leds - buzzer Ramload: - tftpboot 0x84000000 lede-ar71xx-generic-wpj563-16M-initramfs-uImage.bin - bootm 0x84000000 Install: - tftpboot 0x80500000 lede-ar71xx-generic-wpj563-16M-squashfs-sysupgrade.bin - erase 0x9f030000 +$filesize - erase 0x9f680000 +1 - cp.b $fileaddr 0x9f030000 $filesize Erasing 0x9f680000 is required because uboot defines "bootcmd=bootm 0x9f680000 || bootm 0x9f030000", so it first tries to boot the higher address. I think the 16 mb flash are intended to be used as 8+8mb for a fallback image. In my hardware only the lower address has a bootable image. But to make sure future hardware will boot lede too, I erase one block, so uboot will skip this address. Signed-off-by: Christian Mehlis <christian@m3hlis.de>
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/generic.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 2ad058e845..ebcb183b03 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -825,3 +825,12 @@ define Device/wpj558
IMAGE_SIZE := 16128k
endef
TARGET_DEVICES += wpj558
+
+define Device/wpj563
+ DEVICE_TITLE := Compex WPJ563 (16MB flash)
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
+ BOARDNAME := WPJ563
+ MTDPARTS := spi0.0:192k(u-boot)ro,16128k(firmware),64k(art)ro
+ IMAGE_SIZE := 16128k
+endef
+TARGET_DEVICES += wpj563