aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/tiny-tp-link.mk
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2018-02-21 13:15:17 +0100
committerPiotr Dymacz <pepe2k@gmail.com>2018-04-06 23:11:00 +0200
commitb834487203996e71c5ea25f83488873483b96522 (patch)
treed270217b9635720110c22d0548edeb3937b00b0f /target/linux/ar71xx/image/tiny-tp-link.mk
parent6148c465561cb5ba0b05ba77ecfe7cd42faeb835 (diff)
downloadupstream-b834487203996e71c5ea25f83488873483b96522.tar.gz
upstream-b834487203996e71c5ea25f83488873483b96522.tar.bz2
upstream-b834487203996e71c5ea25f83488873483b96522.zip
ar71xx: add support for TP-Link TL-WR940N v6
Add support for TL-WR940N v6 board. It is pretty much the same as v5 except they only left WAN LED and removed other ones. Installation: flash factory image through WEB UI or use TFTP. Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image/tiny-tp-link.mk')
-rw-r--r--target/linux/ar71xx/image/tiny-tp-link.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/tiny-tp-link.mk b/target/linux/ar71xx/image/tiny-tp-link.mk
index 092d8aa114..2891b9654f 100644
--- a/target/linux/ar71xx/image/tiny-tp-link.mk
+++ b/target/linux/ar71xx/image/tiny-tp-link.mk
@@ -622,6 +622,14 @@ define Device/tl-wr940n-v4
endef
TARGET_DEVICES += tl-wr940n-v4
+define Device/tl-wr940n-v6
+ $(Device/tl-wr940n-v4)
+ DEVICE_TITLE := TP-LINK TL-WR940N v6
+ BOARDNAME := TL-WR940N-v6
+ TPLINK_HWID := 0x09400006
+endef
+TARGET_DEVICES += tl-wr940n-v6
+
define Device/tl-wr941nd-v2
$(Device/tplink-4m)
DEVICE_TITLE := TP-LINK TL-WR941N/ND v2