aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/tiny-senao.mk
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2018-10-17 17:16:51 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2018-10-17 18:02:16 +0200
commit5f249333090741ecba190855b13c87fd93ca2520 (patch)
treec144e95f11cb83088b86750a5c125ec397860bf4 /target/linux/ar71xx/image/tiny-senao.mk
parentdb6f9d5598a353c94578bd76dbef92dd78f3ae63 (diff)
downloadupstream-5f249333090741ecba190855b13c87fd93ca2520.tar.gz
upstream-5f249333090741ecba190855b13c87fd93ca2520.tar.bz2
upstream-5f249333090741ecba190855b13c87fd93ca2520.zip
ar71xx: Move some targets to tiny
Recent changes on ar71xx (switch to 4.14, memory compaction, ...) cause an increase in kernel size, making it too big for some devices. Move these devices to the tiny target, where kernel symbols and optimization for speed are disabled, reducing the kernel size. Devices: - EnGenius ENS202EXT - OCEDO Koala Compile-tested targets: - ar71xx->generic->default - ar71xx->smallFlash->Default Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target/linux/ar71xx/image/tiny-senao.mk')
-rw-r--r--target/linux/ar71xx/image/tiny-senao.mk41
1 files changed, 41 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/tiny-senao.mk b/target/linux/ar71xx/image/tiny-senao.mk
new file mode 100644
index 0000000000..a241e4a6f5
--- /dev/null
+++ b/target/linux/ar71xx/image/tiny-senao.mk
@@ -0,0 +1,41 @@
+define Build/senao-factory-image
+ mkdir -p $@.senao
+
+ touch $@.senao/FWINFO-OpenWrt-$(REVISION)-$(1)
+ $(CP) $(IMAGE_KERNEL) $@.senao/openwrt-senao-$(1)-uImage-lzma.bin
+ $(CP) $@ $@.senao/openwrt-senao-$(1)-root.squashfs
+
+ $(TAR) -c \
+ --numeric-owner --owner=0 --group=0 --sort=name \
+ $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)") \
+ -C $@.senao . | gzip -9nc > $@
+
+ rm -rf $@.senao
+endef
+
+
+define Device/ens202ext
+ DEVICE_TITLE := EnGenius ENS202EXT
+ BOARDNAME := ENS202EXT
+ DEVICE_PACKAGES := rssileds
+ KERNEL_SIZE := 1536k
+ IMAGE_SIZE := 13632k
+ IMAGES += factory.bin
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),320k(custom)ro,1536k(kernel),12096k(rootfs),2048k(failsafe)ro,64k(art)ro,13632k@0xa0000(firmware)
+ IMAGE/factory.bin := append-rootfs | pad-rootfs | senao-factory-image ens202ext
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += ens202ext
+
+define Device/koala
+ DEVICE_TITLE := OCEDO Koala
+ BOARDNAME := KOALA
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+ KERNEL_SIZE := 1536k
+ IMAGE_SIZE := 7424k
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),1536k(kernel),5888k(rootfs),1536k(kernel2),5888k(rootfs2),1088k(data)ro,64k(id)ro,64k(art)ro,7424k@0x50000(firmware)
+ KERNEL := kernel-bin | patch-cmdline | lzma | uImage lzma
+ KERNEL_INITRAMFS := $$(KERNEL)
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += koala