aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/senao.mk
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2017-06-14 15:23:35 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2017-06-29 10:37:36 +0200
commit656ed7544fb625756ed8969927b976b0e0120ecb (patch)
treed5951182e30a26e6e247859e6418100345e5d277 /target/linux/ar71xx/image/senao.mk
parentbdd3c948729569d2128fbe158eb62d58cd32cf16 (diff)
downloadupstream-656ed7544fb625756ed8969927b976b0e0120ecb.tar.gz
upstream-656ed7544fb625756ed8969927b976b0e0120ecb.tar.bz2
upstream-656ed7544fb625756ed8969927b976b0e0120ecb.zip
ar71xx: fix EnGenius ENS202EXT mtd definition
Use statically defined sizes for kernel and rootfs mtd partitions. Vendor upgrade script writes both firmware parts independently which ends up in a gap between kernel and rootfs images. This results in incorrectly calculated rootfs_data start offset. Also, fix IMAGE_SIZE, DEVICE_PACKAGES and drop redundant KERNEL definition. Fixes FS#835 Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image/senao.mk')
-rw-r--r--target/linux/ar71xx/image/senao.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/senao.mk b/target/linux/ar71xx/image/senao.mk
index 57e3610e5d..dbb7b69f94 100644
--- a/target/linux/ar71xx/image/senao.mk
+++ b/target/linux/ar71xx/image/senao.mk
@@ -20,12 +20,12 @@ endef
define Device/ens202ext
DEVICE_TITLE := EnGenius ENS202EXT
BOARDNAME := ENS202EXT
- DEVICE_PACKAGES += rssileds
+ DEVICE_PACKAGES := rssileds
KERNEL_SIZE := 1536k
- KERNEL := kernel-bin | patch-cmdline | lzma | uImage lzma | check-size $$(KERNEL_SIZE)
- IMAGE_SIZE := 12096k
+ IMAGE_SIZE := 13632k
IMAGES += factory.bin
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),320k(custom)ro,1536k(kernel),12096k(rootfs),2048k(failsafe)ro,64k(art)ro,13632k@0xa0000(firmware)
IMAGE/factory.bin/squashfs := append-rootfs | pad-rootfs | senao-factory-image ens202ext $$$$@
- MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),320k(custom)ro,13632k(firmware),2048k(failsafe)ro,64k(art)ro
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
endef
TARGET_DEVICES += ens202ext