aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic.mk
diff options
context:
space:
mode:
authorSebastian Kinne <contact@sebkinne.com>2018-02-13 13:26:33 +1100
committerPiotr Dymacz <pepe2k@gmail.com>2018-02-22 18:53:22 +0100
commit950b278c81cb380df869b0dadc02fa8258a91a6a (patch)
treeb00daa6a85bd2e8cbe5cfdc125afca92fe1fd4bd /target/linux/ar71xx/image/generic.mk
parent2ea98fc39b21392c1556d6768604f54a578278d4 (diff)
downloadupstream-950b278c81cb380df869b0dadc02fa8258a91a6a.tar.gz
upstream-950b278c81cb380df869b0dadc02fa8258a91a6a.tar.bz2
upstream-950b278c81cb380df869b0dadc02fa8258a91a6a.zip
ar71xx: add support for AR9331 based Hak5 devices
This adds support for AR9331 based Hak5 penetration testing tools: - WiFi Pineapple NANO - LAN Turtle - Packet Squirrel WiFi Pineapple NANO specifications: - SoC: Atheros AR9331 (400 MHz) - RAM: 64 MB (DDR2) - FLASH: 16 MB - WiFi: 1T1R AR9331 (built-in), 1T1R AR9271 (built-in via USB bus) - Ethernet: 1x FE over USB (ASIX AX88772A) - Ports: 2x RP-SMA for antennas, 1x USB 2.0 (host), 1x micro SD - Power: USB 5 V, 1.5 A - Other: status LED, reset button LAN Turtle specifications: - SoC: Atheros AR9331 (400 MHz) - RAM: 64 MB (DDR2) - FLASH: 16 MB - WiFi: none - Ethernet: 1x FE (AR9331), 1x FE over USB (Realtek RTL8152B) - Ports: 1x RJ45, version dependent: micro SD or 3G SIM slot - Power: USB 5 V, 0.5 A - Other: status LED, reset button (inside, on PCB) Packet Squirrel specifications: - SoC: Atheros AR9331 (400 MHz) - RAM: 64 MB (DDR2) - FLASH: 16 MB - WiFi: none - Ethernet: 2x FE (AR9331) - Ports: 2x RJ45, 1x USB 2.0 - Power: USB 5 V, 0.12 A - Other: status LED, reset button, 4-way switch Flash instructions for all 3 devices: Original firmware is based on OpenWrt. Use sysupgrade via SSH to flash. Signed-off-by: Sebastian Kinne <contact@sebkinne.com> [squashed commits, combined and reworked mach files, aligned board naming with general convention, fixed minor issues, tested on real hardware, reworded commit subject and description] Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image/generic.mk')
-rw-r--r--target/linux/ar71xx/image/generic.mk39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 137716d439..539fd3c1fe 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -484,6 +484,19 @@ define Device/gl-usb150
endef
TARGET_DEVICES += gl-usb150
+define Device/lan-turtle
+ $(Device/tplink-16mlzma)
+ DEVICE_TITLE := Hak5 LAN Turtle
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage \
+ -kmod-ath9k -swconfig -uboot-envtools -wpad-mini
+ BOARDNAME := LAN-TURTLE
+ DEVICE_PROFILE := LANTURTLE
+ TPLINK_HWID := 0x5348334c
+ CONSOLE := ttyATH0,115200
+ IMAGES := sysupgrade.bin
+endef
+TARGET_DEVICES += lan-turtle
+
define Device/lima
DEVICE_TITLE := 8devices Lima
DEVICE_PACKAGES := kmod-usb-core kmod-usb2
@@ -656,6 +669,19 @@ define Device/cr5000-nocloud
endef
TARGET_DEVICES += cr5000-nocloud
+define Device/packet-squirrel
+ $(Device/tplink-16mlzma)
+ DEVICE_TITLE := Hak5 Packet Squirrel
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 \
+ -kmod-ath9k -swconfig -uboot-envtools -wpad-mini
+ BOARDNAME := PACKET-SQUIRREL
+ DEVICE_PROFILE := PACKETSQUIRREL
+ TPLINK_HWID := 0x5351524c
+ CONSOLE := ttyATH0,115200
+ IMAGES := sysupgrade.bin
+endef
+TARGET_DEVICES += packet-squirrel
+
define Device/pqi-air-pen
DEVICE_TITLE := PQI Air Pen
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage
@@ -1125,6 +1151,19 @@ define Device/wam250
endef
TARGET_DEVICES += wam250
+define Device/wifi-pineapple-nano
+ $(Device/tplink-16mlzma)
+ DEVICE_TITLE := Hak5 WiFi Pineapple NANO
+ DEVICE_PACKAGES := kmod-ath9k-htc kmod-usb-core kmod-usb2 kmod-usb-storage \
+ -swconfig -uboot-envtools
+ BOARDNAME := WIFI-PINEAPPLE-NANO
+ DEVICE_PROFILE := WIFIPINEAPPLENANO
+ TPLINK_HWID := 0x4e414e4f
+ CONSOLE := ttyATH0,115200
+ IMAGES := sysupgrade.bin
+endef
+TARGET_DEVICES += wifi-pineapple-nano
+
define Device/wlr8100
DEVICE_TITLE := Sitecom WLR-8100
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-usb3 \