aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic.mk
diff options
context:
space:
mode:
authorLuo chongjun <luochongjun@gl-inet.com>2018-05-25 18:06:37 +0800
committerJohn Crispin <john@phrozen.org>2018-05-27 09:26:09 +0200
commit312d7a4a5aaac8df714da5ad25d8b83a09c9e68c (patch)
treebea4cb37ec2ca8db7260cb11f5af30ddee0dec9f /target/linux/ar71xx/image/generic.mk
parent27eab4fa578d696ab55b6264a1b35fad6488b664 (diff)
downloadupstream-312d7a4a5aaac8df714da5ad25d8b83a09c9e68c.tar.gz
upstream-312d7a4a5aaac8df714da5ad25d8b83a09c9e68c.tar.bz2
upstream-312d7a4a5aaac8df714da5ad25d8b83a09c9e68c.zip
ar71xx: add support for GL.iNet GL-AR750S
This patch adds supports for GL-AR750S. Specification: - SOC: QCA9563 (775MHz) - Flash: 16 MiB (W25Q128FVSG) - RAM: 128 MiB DDR2 - Ethernet: 2x 1Gbps LAN + 1x 1Gbps WAN - Wireless: 2.4GHz (bgn) and 5GHz (ac) - USB: 1x USB 2.0 port - Button: 1x switch button, 1x reset button - LED: 3x LEDS (green) Flash instruction: Apply factory image via web-gui. Signed-off-by: Luo chongjun <luochongjun@gl-inet.com>
Diffstat (limited to 'target/linux/ar71xx/image/generic.mk')
-rw-r--r--target/linux/ar71xx/image/generic.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index bceeba0009..e57f8a2731 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -461,6 +461,19 @@ define Device/gl-ar750
endef
TARGET_DEVICES += gl-ar750
+define Device/gl-ar750s
+ DEVICE_TITLE := GL.iNet GL-AR750S
+ DEVICE_PACKAGES := kmod-ath10k ath10k-firmware-qca9887 kmod-usb-core \
+ kmod-usb2 kmod-usb-storage
+ BOARDNAME := GL-AR750S
+ SUPPORTED_DEVICES := gl-ar750s
+ IMAGE_SIZE := 16000k
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),64k(art)ro,-(firmware)
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += gl-ar750s
+
define Device/gl-domino
DEVICE_TITLE := GL.iNet Domino Pi
DEVICE_PACKAGES := kmod-usb-core kmod-usb2